: Help! Stuck at dealership while on road trip with check engine light



muohio
04-14-12, 02:01 PM
I'm in a little bit of a panic since I'm 200 miles from home and 300 from my destination.

Was on the freeway with cruise control engaged at 72mph. Out of nowhere, the display came on with "Service Stability System", then the car went into "Reduced Power Mode" at which point I pulled off the road. Turned the car off and restarted it and it idled really rough. I turned it back off, let it set for 20 minutes while dealing with OnStar. After that was complete, I cycled the stability system while in accessory mode and restarted the car. It came on and ran fine, also the check engine light went away. I had OnStar run a diagnostic check and they didn't show anything. I'm currently sitting at the Cadillac dealership, but they don't inspire as much confidence as Hennessey in Atlanta (where purchased). Any suggestions or advice?

Overall, I'm extremely happy with the OnStar service, but very sad that I won't be able to visit my parents unless I can get back on the road safely. Also, is it a smart move to flatbed it back to my home dealership if work is necessary?

Thanks!

jb_bgg
04-14-12, 07:41 PM
I got that error tracking recently. Onstar found nothing so I kept running the rest of the day even though it came on and off intermittently. Did not go into reduced power mode in my case. If the dealer doesn't find anything if I were you I'd just keep on going, cycling if necessary. Could also start the trip in competition mode or disable completely which could eliminate the source of the problem and CEL.

Trapspeed
04-14-12, 09:53 PM
How did it work out?

muohio
04-14-12, 10:12 PM
Well, the dealership pulled the codes and found P012B and P0068, but the check engine light was off when they looked at it. I drove the rest of the 320 miles to Ohio and didn't have any problems. Hopefully it was a fluke and will not come back. I had them undo the p-valve changes that where done when the car was tuned. Luckily I had the hose with me.

Trapspeed
04-15-12, 12:06 AM
Good. Happy to hear it worked out in the end.

Cadillac Cust Svc
04-16-12, 11:04 AM
Well, the dealership pulled the codes and found P012B and P0068, but the check engine light was off when they looked at it. I drove the rest of the 320 miles to Ohio and didn't have any problems. Hopefully it was a fluke and will not come back. I had them undo the p-valve changes that where done when the car was tuned. Luckily I had the hose with me.

muohio,

I'm glad that you made it up to Ohio okay, but also terribly sorry that your trip was interrupted like it was. Safe travels back, and if we can be of any assistance please don't hesitate to get in touch here on the forum in a private message.

Best,
Sarah (Assisting Katie)
Cadillac Customer Service