: Passenger Seat dead and Heated/Cooled Seating



Ghost Deany
03-15-12, 10:35 AM
on my 07 this morning after remote starting and driving for 10 mins, i realized my seat wasnt getting warm. I fixed it about a month ago by re wiring the harness cause it was burned. It has worked fine ever since. Now this morning, not only did the heated and cooled seats not work, but the passenger seat is dead completely, wont move, and it doesn't even make a click when you try the adjust levers. Any ideas?

Ghost Deany
03-15-12, 05:30 PM
Strange, i had one of those California Scent air freshener cans under the seat, it was on top of one of the control boxes, i took it off and now everthing seems to be working again?

Cadillac Cust Svc
03-15-12, 07:36 PM
Strange, i had one of those California Scent air freshener cans under the seat, it was on top of one of the control boxes, i took it off and now everthing seems to be working again?
Interesting! I'm happy the problem appears to be resolved, but please let us know if the issue pops up again or if there are further updates to the situation. And I'm always available via private message and happy to help if you have any follow-up questions.

Best,

Katie
Cadillac Customer Service

Playdrv4me
03-16-12, 04:19 AM
BTSOOM, but at least it works again.

tracibrillhart
03-19-12, 11:37 PM
My 07 just did the same thing! Anything I can do to fix this or is a visit to the shop my only option?

Cadillac Cust Svc
03-20-12, 12:35 PM
Very sorry to hear that, tracibrillhart. I would definitely recommend a dealer trip to try to find a resolution, but I'm sure you'll read some great replies on the matter. Please feel free to email me at Katie_Lucille@gmexpert.com anytime if you'd like me to investigate concerns on your behalf.

Best,

Katie
Cadillac Customer Service

Playdrv4me
03-20-12, 02:19 PM
My 07 just did the same thing! Anything I can do to fix this or is a visit to the shop my only option?

Passenger seat not moving at all, or the heating/cooling not functioning?

tracibrillhart
03-22-12, 10:33 AM
Heat/cool not working and seat not moving either. All on passenger side

Ghost Deany
03-22-12, 10:53 AM
Try moving some of the connectors around under there. Mine did it again and i just made sure all the harnesses were tightly connected and haven't had a problem since.

mikemjohnson
06-27-12, 08:38 AM
same here, both seats' a/c heat function does not work, and passenger seat is dead in water. trying to find time to take passenger seat out to look at IT

Esanti1710
06-30-12, 11:23 AM
I've just developed the same problem on my '07 this past week. No cooling function on either seat and the passenger seat does not move. The Cooled Seats fuse is intact. I also tried swapping the driver and passenger seat circuit breakers and nothing changes. I did notice that the drivers seat will still make a clicking sound once the circuit breaker is removed even though the seat won't move, whereas the passenger seat makes no sounds at all, with or without the circuit breaker. I'm no longer under warranty so going to the dealer to have them fish around at $120 an hour is not an option. Particularly if they do not fix it on the first go round. Has anybody had this happen and find the problem? Please share solution.

Rustico
06-30-12, 03:03 PM
The secret to diagnosising this problem lies in the California Scent air freshener cans under the seat!

Ghost Deany
07-01-12, 08:58 PM
My problem was this. Make sure the white plastic thing is clipped on tight. 94102