: Help...Service Engine Light



mbokishet
11-12-04, 10:33 AM
The service engine light came on about a week ago on my 98 Deville. I checked the codes....got at PO442. Have no idea what that means. Today after getting gas, I tried to start the car and starting was diabled. Waited for the 3 minutes and she started. Checked codes when I got home. Still have PO442, now I also have PO463. What are these codes and what is the fix for their problems. I would greatly appreciate any help I can get. I am beating head off wall, cause eveytime I turn around there is something wrong with this car. :banghead:

JimD
11-12-04, 10:51 AM
P0442 = Evaporative Emission (EVAP) System Small Leak Detected. Could be as simple as gas cap not properly installed, or a defective gas cap.

P0463 = Fuel Level Sensor Circuit High Voltage. Several possibilities here.

Clear the codes and see if they return.

mbokishet
11-12-04, 11:44 AM
Thanks Jim.......will get new gas cap today and try it. Would be great if for once it was an inexpensive repair. :D

mbokishet
12-02-04, 08:17 PM
Back to square one guys. Gas cap worked for about two weeks. Now having really strange problem. Light came on again. If you fill the car with gas and reset computer the light stays off. As soon as the gas gauge reads seven gallons the light comes back on. Fill'er up again reset computer....ok till 7 gallons. I am really stumped. Can you help? Thanks!

Ranger
12-02-04, 10:26 PM
What codes are you getting now? Maybe you fixed the P0442 with the gas cap but the fuel level sensor is bad. Sounds like you had two seperate issues.

mbokishet
02-10-05, 08:49 PM
Still getting a PO442 code......even with new gas cap......I am confused.

Ranger
02-10-05, 10:24 PM
Check all the vacuum hoses on the evap solenoid. It is mounted on the rear cam cover (driver side) if memory serves me correctly.