: need help with rough running northstsar



FREDFLYPOGGER
01-27-12, 02:26 PM
hi
My daily driver is a 01 eldorado with the northstar engine. today i installed new fuel injectors ,fuel pressure regulator,new intake gaskets., and while i was at it i installed a starter as well. it went back together pretty easy but when i started it ran very rough,stumbling. it stays running, but like i said it idles very very rough. i double checked all my connections,it did set a code p308 cylinder 8 misfire. I almost seems like the map sensor or maf sensor isn't connected but they are. could it be the wrong injectors? i checked the part #'s and they were identical to the old ones. i am lost here. any help would be appreciated.
UPDATE
swapped back the old injectors and the car runs great. Bought these injectors for $90 on ebay, i guess you get what you pay for. i was suspicious when the boxes weren't GM. ordered a new set from rock auto.

ternstes
01-27-12, 02:42 PM
What lead you to install all new fuel injectors? I would check the #8 fuel injector, make sure it pulses with the car running. Check for vacuum leaks as well around the intake.

FREDFLYPOGGER
01-27-12, 02:57 PM
hi
now i am getting p0300 random / multiple cylnider misfire. ran a little better but still rough. which is cylinder 8 ? can't find a diagram in the service manual
thanks
todd

Ranger
01-27-12, 04:34 PM
#8 should be the front drivers side

1357
2468

Submariner409
01-27-12, 05:05 PM
FRED, Click on my username, open my profile - left column, 2 picture albums - 6 pages of pics, diagrams, and notes on our engines.

.............and remove your e-mail from your post.

ternstes
01-29-12, 07:23 AM
I don't get it. If your car is running fine now, why replace the injectors again?