: Could Sensors Be The Problem



italiantnt
11-11-04, 10:58 AM
Is It Possible For Sensors Tho Make My 2003 Cts Stall......is This Possible, I Stall And In 10 In I Start Right Up..i Dont Get It

Mbai2
11-11-04, 01:11 PM
I would check for any corroded wiring. If wires are shorting or disconnecting that have to do with the ECM keeping the engine running, stalling would indefinately occur. The point of corrosion will be hard to pinpoint though.

I remember a while back that a car (can't remember which model) had wiring that rubbed against the door hinge everytime it was opened and shut. Eventually the insulation wore off and began to short on the frame of the car which caused it to stall.

ctsvett
11-15-04, 12:38 AM
I have a weird issue on my V that happens sometimes. When I start it I run the key through the first two steps (acc, run) and right into the start and let go. It has happened about 3 times since I have owned it (first time freaked me out) where the key "jumped" back beyond the "run" position. This told the car to turn off and it sounded like it may have stalled. I realized this when I turned the key forward, it clicked into the correct position. Maybe you did what I did and hte key was not all the way in the "run" position..

Let us know.

Reed
http://www.cadillacfaq.com

italiantnt
11-15-04, 03:39 PM
The Dealership Just Called Me And Told Me My Crank Shaft Position Sensor Was Bad....ha Ha Ha./...what In Gods Name Is That!..well Anyway My Babys Back In My Driveway.

10secvette
11-23-05, 07:39 PM
could be