: 2000-2005 Deville - Heater/AC blower motor problems - Quick Fix



MinnesotaDeville
01-23-12, 10:51 PM
This was a quick fix that I did to restore function to my blower motor. Just wanted to post this because I noticed a lot of threads pleading for help but really no solutions. This is just one thing to check before ordering a new blower motor.

Symptoms I was having
- Blower motor not working, minute heat or no air blowing out the dash/defrosters/floor. ect...
- Occasionally works turns on and off
- Slamming the right hand side passenger door would temporarily fix the problem
- Tapping on the blower motor metal housing with the handle of a screw driver would temporarily fix the problem
- Wiggle the blower motor power source - Blower motor turns on and off
- Wiggle the housing - Blower motor turns on and off

Quick Fix - Take blower motor out from underneath the dash (passengers side - 3 screws). Took the metal housing off the bottom of the motor so you can see the brushes and the copper color metal that they come in contact with. I took a small file and filed the brushes slightly. Then I took the file and filed away the musty tarnished brass/copper or what ever the metal is. Got it nice and shiny again. The sub housing that holds the brushes, remove that from the main housing. You will need to pinch the brushes to retract the springs so you can get the sub housing back on the contact. Then put the main cover or housing 2 screws back on, plug the blower motor back in and she should start spinning. That was just my case and what I did to fix it. If you have some of the symptoms above you might want to try it. It will save you some $$$ about $250 from the stealership.. Ebay has new motors for about $50. This whole ordeal took me about 45 mins with a broken knee... Anyone is capable...

Hope this helps as thats all I am trying to do, I know my parts terminology is not up to par... GOOD LUCK!!!

00 Deville
01-24-12, 10:15 AM
Take blower motor out from underneath the dash (passengers side - 3 screws)... This whole ordeal took me about 45 mins with a broken knee... Anyone is capable...

Nice fix... I see that you are one of the lucky 2002 Deville owners that has the design 2 blower assembly. What's the build date on your car?

Design #1 ran from 2000-2002 and is a PIA to change... more than 3 screws and the assembly is too large to pull from under the dash... hence the design change.

Design #2 ran from 2002-2005 and has a much smaller housing and simple to change (only 3 screws).

The usual problem with the design #1 blowers is a broken wire (bare copper) that runs to one of the motors brushes.

snapr
07-05-12, 06:34 PM
If you have design #1, how can you do without being avble to pull from under dash. UGGGG!

kevphill
12-05-12, 08:11 PM
Followed your directions and saved two hour labor and $380 in parts. Thanks.
kp

szglvs
02-16-13, 03:37 PM
This worked out great for me too.
Thank you so much.
2004 Cadillac Deville

whb
04-10-13, 02:12 PM
What do you remove to get to the blower motor?

raceking
04-28-13, 02:11 PM
Worked for me as well...Thanks
2005 DHS

cady29204
05-26-13, 09:37 AM
Thanks for the instructions with pics. I had the exact symptoms with my 2003 Deville blower motor. I followed your advice. Its been working fine since. I was tapping the motor housing several times each week before.

Jamer567
07-29-13, 02:21 PM
Thank you so much for your illustration!! Worked perfectly!

redfishsc
09-05-13, 06:02 PM
My blower has been acting up lately (2003), sometimes giving me half the air flow, and today it just crapped completely.

Seeing your advice here, I went and cranked the car and left the AC running, and slammed the passenger door. Blower came on magically lol.

So I guess I know what my Saturday afternoon project will be. I'll report back here when I complete it.


Oddly, the EXACT same problem just started on my old 1990 GMC 1500 a month ago. The AC hasn't worked in years so I haven't messed with it, but with winter coming I'm going to need the fan for the defrost. Hoping it's the same problem. If anyone here has replaced a blower in an early 90's GM C/K series, I would appreciate a PM from you thanks!

redfishsc
10-18-13, 07:39 PM
Finally got a chance to actually fix this today, worked like a charm. Thanks for posting this. As long as you don't mind laying down on your back, in the seat, head under the dash, this really is a straightforward project.

Two small bolts hold on the plastic shroud-- three bolts hold in the blower motor (along with an electric pigtail and a vent hose), and two screws to access the inner parts of the motor.

I cleaned the contact/brushes with 320g sandpaper, and blew it out thoroughly. It was VERY cruddy.

bellguy24
10-26-13, 11:15 PM
Thanks very much Minnesota!
Just fixed my Dad's '03 Talisman before he heads to Fla. Probably the easiest repair I have ever done on a GM.
Definitely worth trying to fix it before buying a new one. Nothing to lose.
(It sounds a little noisier now but at least it works. Told him to turn up the radio...lol)

Jawbone
11-12-13, 12:14 PM
Cleaning the brushes worked for me too...great fix, Thanks for posting. I had to same exact symptoms -intermittent, slamming passenger door- My car 2005 Deville....One note: the caddy factory service manual has you removing half the dashboard to gain access to this blower motor. Not necessary. Just follow the instructions in these posts to remove the blower. 1) remove kick panel under glove box- 2 screws-. 2) remove electrical connector from blower motor. 3) slide off and remove small rubber vent tube from blower motor. 4) remove 3 mounting screws to remover blower motor...That simple. Thanks again for this excellent repair info!!!

mn_vette
11-25-13, 04:35 PM
Add me to the list of the people that this has worked for. Thanks for posting this. Mine was also very cruddy and my contacts had worn down enough to fit the curve of the shaft. I sanded them back into a square shape and cleaned up the shaft. Everythign is nice and shiney now and the blower works great. You can imagine how annoying it is to have a blower that doesn't work when you need to go to work early on a cold November morning in Michigan.

fredjh
12-24-13, 03:53 PM
Me too. Believe me I am not a mechanic but this was really straight forward. Hardest part was getting the screws started on the reinstall, but isn't that always the case. Used a Dremel tool to clean things up, but be cautious as the brushes are quite soft. Two hints for the auto knowledge impaired like me. 1. the blower is directly below the glove box. 2. Compressing the brushes for the re-assembly is tricky. No room. I took one of the little cartons that butter sticks come in. Cut two strips the length of the carton and about 1/2 - 3/4 inches wide. Put two folds so one end would cover the brushes and come up around the outside so they could be held in place as the cap is slipped over the rotor. Because the carton material is thin and slippery the brushes slide easily over the lip of the rotor. Just after they have started over the rotor just pull the strips out. Thanks to all.

bcm
05-14-15, 06:51 PM
[B]It worked for me to on my 2004 Deville![B] I did just as you advised and the fan motor is running like new. My symptoms were the same except if I slammed the
driver's door fairly hard the fan would come on. Sometimes that didn't even work. I would have the power on the A/C compressor set to off with the fan power button on driving down the highway. Then all the sudden the fan would come on going over a part of rough roadway. When the fan came on, I would reach over and turn on the
compressor on (A/C On/off button).
I did find a quick and easy way to sand off the corrosion off on the copper above the armature. At the hardware store get a roll of Plumber's Cloth. Its about an inch wide and costs only a few bucks. Tear off about 18 to 20 inches of the roll and cut a strip lengthwise of the piece about 1/2 in wide. I sat down in a lawn chair and put
the fan between my knees to hold it steady. Place the 1/2 inch wide strip on the corroded copper, one end of the 1/2 inch wide strip in each hand. Then pull back and
forth on the strip just as a shoe shine boy would polishing a pair of shoes with a cloth. Periodically, stop and rotate the fan a 1/4 turn between your knees and repeat the process. This is a very simple way to sand the copper evenly. Be careful not to sand the plastic piece above the copper that helps to steady the shaft center in the
housing. I got the idea from when I sand copper tubing in plumbing to get the copper bright before soldering pieces together. Being an ol' country boy I've found one
technique works for more than one application at times.

Ranger
05-15-15, 08:47 PM
I went through this twice on my daughters '04 SLS. The fix was short lived. In the end I still had to replace the blower. By that time I was pretty adept at removing and reinstalling it.