: Radio no sound ???



wyched7006
01-23-12, 07:19 PM
My radio comes on , you can tune stations, it shows which songs are playing, cd track show when I insert cd still no sound
I notice the letters msg tp some times not all ways showing
can someone give me some hints as how to fix this ????
I ck the amp fuse under rear seat driver side

chazglenn3
01-23-12, 07:35 PM
Bose amplifier possibly gone bad?

EChas3
01-23-12, 07:50 PM
Maybe it's just the Amp Fuse.

STS05blk
01-24-12, 09:58 AM
Im having the same problem. Parked my car one night with everything working perfect. The next day started it up and no sound. The radio works and is playing the cds, radio stations and gps. When I push the buttons on the touch screen the radio itself still beeps but there is no sound from the speakers.

radioSteve
01-25-12, 11:32 PM
Can you guys hear any kind of hiss from any of the speakers? You would have to put your ear right up to one of the speakers. If you hear nothing at all you might want to check to see if you are getting power to the amp. Even if the fuse is good the relay that switches it on and off may be bad. If it is then its a simple plug in a new relay and away you go.

ddalder
01-26-12, 12:01 AM
If your door chimes work the amplifier will be functioning, at least to some degree. A Tech2 scan tool would be your friend right about now.

The amplifier always has power. It is turned on and off by messaging over the GMLAN bus. There is no relay involved externally to the amplifier.

wyched7006
01-26-12, 07:26 AM
Thanks for all of your replies I found out my caddie is still under bumper to bumper war. I took it to the dealer and they replaced the radio prob fixed :)

EChas3
01-26-12, 09:12 PM
Yeah, even the turn signal clicking actually is produced by the Nav!