: Check Engine Lite on



ruby 1
01-06-12, 06:58 PM
Yep 600 miles logged in. At dealer for pressure test. Now driving a CTS sedan:(

smackdownCTSV
01-06-12, 07:27 PM
Did they tell you what the code was?

rednumbers
01-07-12, 01:38 AM
Took my car in for the check engine. My code was p069e. I had my afraid on my car and suspected that it was the caused. Took it off and went back to stock and the light turned back on. Dealer could not find an issue and could not replicate the light. They said that their should of been more than 1 code that should poped p. I got the car back and seems to drive fine without any light. Putting back the afraid tomorrow and see what happens

ruby 1
01-07-12, 03:30 AM
Something about the evaporative emission system. They test by putting pressure and smoke in the gas tank the serv adv said. Then check for leaks.

ruby 1
01-07-12, 05:25 PM
Well the code is po442. for those that are wondering. I don't know what that means?

smackdownCTSV
01-08-12, 10:32 AM
Why are you afraid?

----------

And the code is EVAP Emissions Control System Leak. Did you get gas? Check the gas cap.

ruby 1
01-08-12, 03:56 PM
Got gas 1/4 tank ago. Check cap and drove another 1/4 tank and on on off cycle at least 10 times. Dealer will test on monday.

ruby 1
01-09-12, 04:02 PM
Gas tank leak per Serv adviser. New tank ordered for overnight delivery.

rednumbers
01-09-12, 11:30 PM
Sorry auto misspell. Airaid.


I put the filter back on and the light came back on. Guess its the filter. Interesting I had it on for over 4k miles. No problems to now. Weird part is it turns on off. Not sure what's going on

smackdownCTSV
01-10-12, 08:50 AM
I've never heard of an intake causing a p069e code. That's fuel pump related. I suppose it's possible for the dealer to say the CAI is trying to compensate for the extra air. As to why it's come on now? Only change is the weather. Cold air can do that to you which is why it's a good idea to have a winter tune and a summer tune.

ruby 1
01-12-12, 01:21 AM
Fuel tank replaced. Drove 8 miles home from dealer. So far good.

ruby 1
02-02-12, 12:48 AM
CEL back on at 971 miles. Dealer replaced evap canister. Hope this is the last of this problem!