: Rear Brake Lights Stay On.



Mike06train
01-03-12, 01:35 PM
All 3 of the rear brake lights are stuck on as soon as the truck is started but only with the key in not if you use the remote start. But, as soon as you put the key in all lights are on. I dropped it off at the shop today for that and 2 other issues so I'll see whats going on.

48Dodge
01-03-12, 01:56 PM
I'm going to guess that it's simply the brake light switch that is attached to the brake pedal arm. I replaced mine not too long ago when my cruise control didn't work. I believe the switch is about $30 from the dealer, cheaper online, but shipping brings it close to dealer cost. Takes less than 5 minutes to replace

Cadillac Cust Svc
01-03-12, 03:26 PM
Mike06train,

I'm sorry to hear you have been experiencing problems with your vehicle. Keep us updated on what you find out about your vehicle.

Evan, Cadillac Customer Service

hannity
01-03-12, 04:57 PM
All 3 of the rear brake lights are stuck on as soon as the truck is started but only with the key in not if you use the remote start. But, as soon as you put the key in all lights are on. I dropped it off at the shop today for that and 2 other issues so I'll see whats going on.

There is a small plunger that looks like half of a pen cap. When depressed your brake lights turn off It has probably broken. However if you did not see any piece of it laying on the floor mat then it is more or less an electrical issue. Keep us informed.

Mike06train
01-04-12, 11:50 AM
Yes, it was the switch. I don't have any free time right now thats why I droped it off at the shop who takes care of my work trucks for me. Most of the things that were bothering me were small and they took care of them. The one thing they showed me that has me twisted though might cost some big $. When they called me over to the shop he pointed the the drivers side exhaust manifold's rear bolt. As soon as I saw it I just shook my head and am more then a little mad at myself for not seeing it when I bought it. The threads must have stripped out in the head and some rube just forced an oversized bolt with a fender washer on it. It's not leaking but i'm really not ok with it. I don't know if this would fall under the 100k drivetrain warrenty or not but this could cost some cash to fix and I'm not comfortable leting it go.