: CEL 02 sensors



JAYRAT
12-14-11, 11:46 PM
so i am breaking down and changing 02 sensors. Code told it was bank 1&2 02 sensors, and i am tired of light coming off and on, well light is steady now. warranty is out, my chevy Z71 has 150,00 been put through mud, water,snow,sand and city driving no CEL, My 07 STS 50,000 highway miles and pampered. what is the problem with cadillac.

ddalder
12-15-11, 12:02 AM
The pitfall some people fall into is the belief that a DTC will point to the source of the problem. So keep in mind that many systems affect each other. If every DTC led you straight to the problem, anybody and everybody could be a technician. Case in point... we have roughly 100 of the same type of vehicle in our fleet. Consistently we would see a MIL (Malfunction Indicator Lamp) or GM's name for the check engine light. The DTC's generated frequently pointed to fuel trim problems and bad O2 sensors. O2 sensors are not the same as sensors 15 years ago. Yes they fail, but not nearly with the frequency many years back and not nearly as often as people blame them as the problem. It's important to follow the established diagnostic testing and not just what a code reader tells you. In almost every case we experienced, the fault has been isolated to a vacuum line that was not properly secured following other routine service. A system "upstream" was not functioning as engineered but the presentation by internal diagnostics was a fault in another part of the system. The point... don't jump on codes alone or you might spend a lot of money getting to the wrong conclusion. Code readers are one of many tools and need to be used as "part" of the process. I will be very surprised if it turns out that all your O2 sensors are actually faulty.

JAYRAT
12-15-11, 12:40 AM
Thanks ddalder that calmed me down just venting (frustrated). I will step back and check upstream too. Car runs great just don't like CEL on, want everything working properly. It's that my other GM gets treated way worse than the sts and no problem. Consistency is the word i am looking for.

ddalder
12-15-11, 12:44 AM
No problem. Just offering another point of view. Follow the process and I'm confident you'll get to the root of the problem regardless of whether it's sensors or something else. Frustrating? Yes! It drove us crazy for a while.

JAYRAT
12-18-11, 03:53 AM
Hey ddalder, i started at air filter box cleaned MAF sensor, tightened bolts on air filter box to MAF sensor, rechecked intake manifold bolts. CEL is off! Thanks

ddalder
12-18-11, 02:03 PM
That's great news! Going from a steady on, to off is very encouraging. Well done.