: Gap between weatherstrip and plastic cover at rear entry



Jochen
12-11-11, 10:43 AM
Hi,

i have a little, but annoying problem on both sides on the rear entry of my 07 Escalade.
Between the weatherstrip and the plastic sil cover is a small gap. You can even see some cable routing below the plastic cover that says "Cadillac".
Just have a look at the picture.....

Does anyone has the same thing, too? Did you get to fix it and how?

Any help is appreciated!

Thanks!

Jochen

99embrey
12-11-11, 03:11 PM
Same with mine on pass side.

Sent from my PC36100 using Tapatalk

48548m
12-11-11, 08:55 PM
Pulling on the rubber doesn't help either? I had one seal that was pushed in, but I pulled it out with a pick and it stayed...

hcvone
12-12-11, 09:12 AM
My neighbor truck looked just like that, I used a heat gun (lightly) and got it back to mostly the orignal shape, put a little contact cement on both parts (back of rubber and top edge of plastic molding) and it's been fine that last time I looked

Cadillac Cust Svc
12-12-11, 09:41 AM
You could contact your local dealer and see if they have had any other issues the same as this. They may have an easy fix for it. Let us know what you find out.
Breanne
Cadillac Customer Service

Jochen
12-12-11, 10:28 AM
Thanks for your posts!

I tried a few times pulling the rubber on top of the plastic, but it goes back after a while. Though i never tried to glue the rubber to the plastic.... might be a good idea!

Breanne, i live in germany and we do not have very good customer support for cadillacs here. Hard to find a good dealer....

Thanks again for your ideas.

Jochen

Jochen
02-26-12, 10:05 AM
Good morning!

finally i had the time to fix that gapthing...

What i did:
I bought a piece of black plastic plate and cut it in shape (1.5 x 10 inch). Used a hot air gun to heat the plastic to bend it in shape.
Finally i glued the plastic strip to the oem plastic cover. I used hot glue gun to do so...

Assembled everything back together... done!

Hope this helps somebody!

Jochen