: Sometimes dead radio



Dave S Texas
12-08-11, 04:55 PM
'87 DeVille radio with slide-equilizer and 8-track player.

Good radio with no problems until recently. When radio turned On, left side speakers front/rear are dead. Sometimes after no specific time, the left side comes on and all is well until the next time I turn it Off. I don't use the tape player, so I don't know if the same problem exists with it. I've never messed with it, so it's not something I did. Ideas where to look for trouble? (Sure like a push-button radio)
Thanks

Dave S Texas
12-09-11, 10:42 AM
hmmm....if no one knows what might be going on with this radio, might anyone know of a replacement radio for this year DeVille or a place to look for replacement? I don't want one that requires a remote to operate. Have one like that in my truck and it is a pita to deal with just to change channels to pre-sets.
I'd really rather get the OE radio to work properly again tho....
Thanks

dennis93coupe
12-11-11, 04:30 PM
Dave sounds like the connection to speakers might be bad. Radios are a dime a dozen in these cars at the salvage yard. I can look, think the same part number was used up to 93. You have the Symphony Sound, correct? You might just want to check the connections on the back of the radio to see if the problem is there. Remove the glove box to assist getting the radio out. you will need to remove the antennae coax before pulling the radio out. The trim on yours is held with a couple of screws at the top. There should be 2 screws on bracket at the top of radio, pull ash tray out and is one screw holding on the bottom.

STS_Seville_Hunter
12-12-11, 05:20 AM
Capacitors on the circuit board are going out.

Dave S Texas
06-29-12, 10:25 PM
Radio cured itself! Hopefully it will stay cured.

Dave S Texas
03-01-13, 11:50 PM
False cure! Finally got around to dealing with this radio problem. 3 of the speakers are bad. 0-Ohms at each. Have 4 new ones on the way. Lasted 25+years so I can't gripe.....
Dave

Dave S Texas
03-07-13, 10:20 PM
Installation of 4 new speakers was the fix.