: Check engine light po174 code



JAYRAT
11-25-11, 12:45 AM
07 sts 49000 miles i changed fuel filter,ran fuel injector cleaner, cleaned maf with spray, cel went out for a while came back on when filled up and im am using unleaded plus. It comes on and off often am really annoyed. Any other suggestions i could try?

C&C
11-25-11, 05:56 AM
Did you get the code first (then try to repair with the maintenance you mentioned) or did the code appear (after the maintenance was performed)? The P0174 is a lean condition; could you have introduced a vacuum leak while performing the service?

JAYRAT
11-25-11, 10:42 AM
Got the code first, then i tried all maintenance i checked all vacumm and checked all intake for leaks even the boot on the throttle body by spraying with carb cleaner and no idle change so i eliminated that. And the light went off for few days then i filled up with fuel and cel came back on. Could it be my fuel cap? Thank you for your time

C&C
11-25-11, 01:09 PM
If it were the fuel cap, your diagnostic code would have been different; perhaps a P0440 or similar 0442 or 0455 series.

You might want to Goggle P0174; plenty to read and then try to figure out what might be your particular problem.

JAYRAT
11-25-11, 02:55 PM
Ok will try that

RippyPartsDept
11-25-11, 03:53 PM
[edit] i should be more careful with what i post

i'll see if i can find any useful info

RippyPartsDept
11-25-11, 03:56 PM
DTC P0174: Fuel Trim System Lean Bank 2

no other codes ? ... must be something only on that one head .... hmm

RippyPartsDept
11-25-11, 04:00 PM
maybe the o2 sensor?

JAYRAT
11-25-11, 05:31 PM
The wife took the STS for a drive and the CEL light is off now. Then i took it for a drive and it stayed off, so maybe when it comes on again i will see if the code is the same. Next is 02 sensor and MAF sensor change if it happens again, process of elimination.

EChas3
11-25-11, 08:18 PM
Any Intake Manifold bolts loose?

JAYRAT
11-25-11, 08:43 PM
Intake manifold bolts? Good question! I do have torque wrench does anybody know torque specs? Any help and suggestions will be and is appreciated! I am going to check bolts even if CEL is not on.

EChas3
11-25-11, 10:35 PM
It's a light setting... measured in inch-pounds... somebody, help us out...

MacMuse
11-25-11, 11:23 PM
EChas - how quickly we forget ...

http://www.cadillacforums.com/forums/cadillac-sts-forum-2005-through-2012/239145-intake-manifold-bolts.html#post2702811

JAYRAT
11-25-11, 11:59 PM
89 in lb got it. thanks alot will tighten them. also bolt sequence i will get on it asap. will keep posting progress, the CEL is off for now.

JAYRAT
11-26-11, 06:07 PM
Cel is still off thanksgiving weekend wife shopping in sts, i guess i will check manifold bolts monday:(

JAYRAT
11-28-11, 12:01 AM
couldn't wait till monday, Just checked manilfold bolts all were loose! Tightened all to specs. CEL light has been off and never came back on lets pray it doesn't. next is the lockpick to the free nav feature while driving for co-pilot. now the new question is, am i going to need to pull whole nav unit out? if so how am i getting in there to pull it out? with all wood trim it looks intimidating

EChas3
11-28-11, 11:34 PM
The only hard part is getting the wiring & connectors back in behind the Nav/Stereo head-end. I used a length of string to hold it snug while replacing it. There's a good video c/o CoastalETech.com.

JAYRAT
11-29-11, 02:04 AM
well drove car today out of town 150 miles one way. after the 150 miles, light came on for about two hours didn't check code. on the way home CEL turned off! 300 mile roundtrip. can anybody guess this one, cause i can't! Car ran fine, cruise control set at 85 mph both ways (i live out in desert)

C&C
11-29-11, 05:55 AM
I would check to see if the code is the same (and has returned); it should still be in history (even though the CEL is off currently).

JAYRAT
11-29-11, 05:37 PM
took it check code history at shop forgot actual numbers but it was bank 1 and 2, 02 sensors. and he cleared them. Since light is off should i wait or change them out? The shop is owned by my cousin i left actual code numbers with him.

C&C
11-29-11, 06:23 PM
I would wait and see if the CEL comes back. In all likelihood it will but there could have been certain conditions, oh I don't know maybe bad fuel, that brought on the original codes and may have successfully cleared itself. (it's a theory anyway) Best of luck with keeping those 'nasties' away.