: 05 STS o2 sensor issue



yamahaRwon
11-14-11, 04:40 PM
Got a code for what appears to be a bad 02 sensor, any one know how to tell what sensor is bad?
Codes for sensors, thanks guys!

BaTu
11-14-11, 05:53 PM
Take the code and Google it. It should say "Bank 1" (the side with Cyl#1 in it) or Bank 2 and either position 1 or 2 (pre cat or post cat).

yamahaRwon
11-14-11, 10:53 PM
P2096 1st code Post CAT fuel Trim System too lean Bank 1
So this the O2 sensor behind the cat most likely?
Thanks for any input
car also had random mis fire p300 code, but i believe that to be related to bad 02 sensor as well..

yamahaRwon
11-15-11, 03:27 PM
so any one remember haveing this code, was it the o2 sensor DS after cat?

BaTu
11-15-11, 06:46 PM
I'd be looking at the Post Cat sensor on the Bank 1 side (B#1 P#2) but my scanner graphs the output of all 4 sensors simultaneously to KNOW before you just go out and buy one ;)

As for history, have you asked in the CTS-V Forum?

yamahaRwon
11-16-11, 01:38 PM
this is for my sts...

yamahaRwon
02-07-12, 01:18 AM
So still trying to figure out what sensor this is. I have multiple cars so she has been just parked since I posted this earlier...... Is that difinative, Bank 1 is the side with Spark plug # 1?
The cadi dealer told me it was the pass side, so then I called the other dealer in my area and they stated it was the D/S.
I know the people on this forum are way smarter then anyone @ the dealerships so....Send me some help!
=)

EChas3
02-07-12, 10:28 PM
Pick a dealer and have them fix it.

dkozloski
02-11-12, 04:16 AM
It's going to be cheaper to drive it to the dealer now than screw around with it and have to have it towed in for repair.