: Thorttle body problem and code p2135



st_pinetree
10-10-11, 03:31 PM
I drug up and old thread on the SRX board to look at this, but haven't had too much luck so I thought I would cross post here and hopefully someone will have some ideas. I had some trouble yesterday coming home from a couple hour trip. Soon after leaving, I was pulling up to a stop light and the car died, when I restarted it the "Check Engine" light was on. The "Traction Control Off" icon was also lit up in the dash. The car resumed for a couple minutes then stumbled hard. I pulled over shut it off and restarted, the traction control light went away but the check engine light remained on. I checked and it had a P2135 code. I cleared it and tried to go again.

Again, stumbling and running poorly a few times, then it went pretty good for about 90 miles. I could tell there was something not quite right as everytime I let up on the gas pedal it would kind of feel wrong, like something was sticking. Eventually, it acted up again and went to reduced power mode, and I thought I was done. My wife called a friend and went to get our other rig, while I was waiting I took off the engine cover, tapped on the throttle body and tried one last time. It fired up and away we went. Cleared the codes and all was right as rain. Today I removed and cleaned the throttle body and relearned the idle. It seems fine now. I guess it will be a wait and see type thing but I'm wondering if any of you have had a throttle body go bad with these types of intermittent symptoms. Now there are no codes.

The only thread I could find on here that was similar ended up being due to a bad piece of wiring going to the throttle body. I removed the loom and inspected the wiring and it seems to look OK.

Ranger
10-10-11, 10:24 PM
Is this a Northstar (not familiar with the SRX)?

What does that code mean? You need to post the code definition along with the codes to help us help you. No one has them memorized.

st_pinetree
10-10-11, 11:54 PM
Sorry, yes it is a Northstar (1st generation SRX, mine is a 2004). The 2135 code is for the throttle position sensor.

Ranger
10-11-11, 11:35 PM
P2135 - Throttle Position (TP) Sensor 1-2 Correlation
:noidea:

st_pinetree
10-12-11, 10:52 PM
It's running fine now, back and forth to work this week. I guess this isn't a common problem, as I've searched and searched for this issue and haven't found much. Someone on this forum in the SRX section had this and finally traced it to the wiring. I will head out on a weekend trip again this weekend and hope it doesn't strand me. If it does it again I will replace the throttle body, as I've traced the wiring and see no issues with that.

Ranger
10-12-11, 11:04 PM
If you are going to replace anything, replace the TPS, not the Tb. The TPS is expensive enough.

st_pinetree
10-13-11, 09:14 AM
Uhhh, the TPS is in the TB, and it's not serviceable. Or, am I missing something?

Ranger
10-13-11, 12:17 PM
Unless GM changed something the TPS IS serviceable. It's right below the IAC valve circled in this picture.

st_pinetree
10-13-11, 03:10 PM
It must have changed. Its not a serviceable part on mine. The good news is the whole TB is only $80.