: Transmission or what?



bobbig
09-15-11, 03:30 PM
When I put my 2010 SRX in park and shut if off, I frequently get a message on the speedometer screen, "Shift to Park." Sometimes it will go off in a few seconds, sometimes I
have to restart the car. This morning, I had to restart it twice and then the GPS screen
didn't go down all the way. I can't lock the car while that message is on the speedometer screen. I've had nothing but strange problems with this car, including the GPS resetting
to Washington, DC. They reset the GPS, and it's been okay, but I no longer trust the car.

Anyone out there have any thoughts???

sube5186
09-15-11, 03:37 PM
Sounds like the car isn't recognizing that it's actually in "Park". Possibly a software update to the TCM (Transmission Control Module) is needed. Have them check it out.


Sube

bobbig
09-16-11, 07:48 PM
Thanks, Sube. I'm taking it in on Monday for the GPS and the "Shift to Park" issue. I'll mention the TCM update.

99ssconv
09-17-11, 08:19 PM
No TCM update for the shift to park message, the micro switch and on the shifter is failing. Needs the shifter replaced. The radio problem needs the U413 USB firmware installed and then the radio will be reflashed with updates..

sube5186
09-18-11, 09:20 PM
99ssconv,

I'm NOT having Nav issues with the Washington, D.C. default, but I have an older version of the map database. Should I still get the U423 update? What will this change? I'm worried about the old adage, "If it ain't broke, don't fix it". Could this update create problems I don't currently have? Is this related to the Bluetooth system? Will it benefit me to have the update if I'm considering getting a new cell phone, or should I wait to see if I have Bluetooth connection problems? Will they do the update at my request if I'm NOT having problems?

Thanks in advance.


Sube

99ssconv
09-19-11, 09:35 PM
99ssconv,

I'm NOT having Nav issues with the Washington, D.C. default, but I have an older version of the map database. Should I still get the U423 update? What will this change? I'm worried about the old adage, "If it ain't broke, don't fix it". Could this update create problems I don't currently have? Is this related to the Bluetooth system? Will it benefit me to have the update if I'm considering getting a new cell phone, or should I wait to see if I have Bluetooth connection problems? Will they do the update at my request if I'm NOT having problems?

Thanks in advance.


Sube

If you have dont have the U413 I would get it done while its in the shop, I have had them come in with 25k miles and the problems finally start. Get it done so you dont have to make a seperate trip, it will act up on you on day. I will post in the next reply what issues this update will fix. Just tell your service advisor that it resets to Wash, DC.

99ssconv
09-19-11, 09:36 PM
Customers may comment on any of the following concerns:






Intermittent rear camera image not displayed, but the guidelines and “Check surroundings for safety” text is displayed.







Rear Camera Always ON.







Rear Camera Fuzzy Display - Wavy lines on rear camera and MAP image. Also MAP and Rear camera image together on screen HMI at same time.







Buick off-screen display does not match IPC color.







Choppy audio playback from the hard disc drive for a few seconds, one to two minutes after start up.







Previous route shown on start up, no guidance provided.







“Unknown Mode” displayed when using an iPod.







Rear park assist icons will be displayed when audible tone is heard (2010 SRX and 2010 late build LaCrosse only).







“UPA Symbols Unavailable” message displayed immediately following a reverse to drive transition.







The clock may reset to 12:00.







The clock is inaccurate.







Unable to adjust the hour and/or minutes on the clock.







Location resets to Washington DC every ignition cycle (corrected once GPS signal is received).







Last audio source is lost after ignition cycle-Defaults back to FM preset (For example-user was listening to CD. Turned off vehicle and waited 10 minutes. Turned on vehicle and now FM playing).







”I Agree” screen is displayed every ignition cycle.







Addresses that have been entered into the radio can be deleted temporarily from the list. After the vehicle sits for about 10 minutes, the addresses have reappeared in the radio.







Navigation guidance pauses during active route guidance. XM Traffic and Weather data are unavailable during this occurrence.







DC charger interference causing no audio condition on start up.







UPA symbol menu selection displayed for vehicles built without RPO UD7 (2010 LaCrosse only).







Difficultly making appropriate menu selections to return to previous screen. (A Back button is added to many screens, and the CONFIG menu selections are displayed in list form with this software update).







Blank display with DVD video as active source during start up.







Audio source reverts to USB/iPod during start up.







Address displayed on the navigation display does not match the address that was given to the OnStar advisor.







No extended XM Weather data displayed if the user selected date is advanced beyond the current date.







Radio presets are erased after programming any module on the vehicle.







XM traffic prompt may not contain the ‘s’ for miles prompting.







Different distances displayed on the IPC and navigation display when in metric mode.







Rear seat audio or rear seat entertainment system does not turn off when the radio is turned off.







Scanning XM displayed on every start up.







1-2 second hesitation when using voice recognition for Bluetooth phone functions.







HVAC pop-up does not expire.







XM list resets to the top without user action - occurs when user turns off an XM category.







Display goes up without user action in key off and door closed. (SRX specific concern)

Jake2010
09-20-11, 08:53 AM
99ssconv.... Thanks for the information! After 14k my SRX has started the an intermittent Wash DC problem. I checked the firmware and I have U306 so the update will probably take care of the problem. I'm sure it's cheaper than replacing the whole radio assembly and I would prefer not having the dash pulled apart too!

I don't want to hijack this thread but since we are talking about a transmission issue as well... in your experience with the 2010 SRX with complaints concerning the erratic shifting, the hesitation and the wildly downshifting. Are these problems being successfully addresses with the TCM programming? I am scheduled for an oil change and would really like this addressed. I know it can be better because I had a 2011 loaner with the same configuration as my 2010 and she shifted great!

Just wondering your thoughts on this and thanks again for your input!

Jake

99ssconv
09-20-11, 10:22 PM
pm me your vin and I can run your calibration numbers and forward you what updates there are. The updates I have installed make a huge difference in the driveability of the vehicle.

99ssconv.... Thanks for the information! After 14k my SRX has started the an intermittent Wash DC problem. I checked the firmware and I have U306 so the update will probably take care of the problem. I'm sure it's cheaper than replacing the whole radio assembly and I would prefer not having the dash pulled apart too!

I don't want to hijack this thread but since we are talking about a transmission issue as well... in your experience with the 2010 SRX with complaints concerning the erratic shifting, the hesitation and the wildly downshifting. Are these problems being successfully addresses with the TCM programming? I am scheduled for an oil change and would really like this addressed. I know it can be better because I had a 2011 loaner with the same configuration as my 2010 and she shifted great!

Just wondering your thoughts on this and thanks again for your input!

Jake