: Seville Front Motor Mount Replacement How-To with Pics



jvc220
09-06-11, 11:12 AM
Disclaimer:
This was written based on a 2000 Seville SLS. Other years and models are probably similar but you will have to confirm for yourself. As with any write-up, only attempt this if you have the proper tools and knowledge to make it a success. This is a repair that can result in damage if not done properly. I take NO responsibility for any damage to your vehicle or harm to you that may result in you using these instructions. I highly recommend having a FSM or Haynes manual to accompany these instructions. Check all torque settings for your application. You may need an alignment after because you will be dropping the subframe.

Introduction:
With all the help I have received from this forum over the years, I thought it was time to give something back. As many of you may know, the front engine mount on the later model Northstar is just not strong enough to last forever, considering the lack of the top “dogbone” mounts the earlier models possessed. The OE mount lasted about 80k miles, which isn’t bad. I purchased the replacement at AutoZone. It has a lifetime warranty, which is good because it only lasted about 6k miles. The next one lasted about 12k miles. I can now do this swap in less than two hours going slow with water and bathroom breaks.

Tools Needed:
-15mm socket – 3/8” drive
-18mm socket – 3/8” drive
-E8 internal star socket – 1/4” drive
-Swivel extension – 3/8” drive
-15mm combination wrench (one with a ratcheting end makes it much easier)
-1-1/4 close ended wrench
-3, 6 and 8 inch extensions
-Torque wrench
-1/4, 3/8 drivers

Removal:
Jack up the vehicle and make sure it is supported well. You MUST support it on the unibody just behind the subframe rear mounts. This is because you will be dropping the subframe to access the mount.
Remove the front wheels. This step is optional but I always do because it allows me greater access and visibility.
Disconnect the level sensor connecting rod, if equipped, by popping one side of the socket off the ball. If you don’t do this, it will pull out by itself when you lower the subframe.
Remove the mount to subframe nut.
Remove the two upper bolts holding the mount bracket to the engine. These are located near the top of the engine but need to be accessed from underneath the car. I use a swivel attachment with an 8 and 6 inch extension as shown (if you have a single extension that is long enough, go for it!). Be very careful with the metal lines running along the subframe.
Remove the lower nuts holding the mount bracket to the engine. One or both may come out with the stud. This is ok because the studs are going to be removed anyway.
Remove the bolt holding the small support bar from the transmission. The other end is open and will slide right off the support bracket stud.
If they didn’t come out earlier, remove the two studs that hold the mount bracket to the engine.
Now place your jack under the front subframe. Place it just touching the subframe and make sure it is tight. Right where the mount bolts through subframe is a good place to locate it.
Loosen the subframe rear bolts (the ones close to the jack stands). There are two on each side. You will want to unscrew them about 75% of the way. Do not remove them entirely and make sure they are still threaded in enough to not strip out (25% should be enough).
Remove the subframe front bolts. There is one on each side. Make sure your jack is placed under the subframe and is sturdy.
SLOWLY lower the subframe to allow you to remove the mount/bracket. Be very careful because there are still brake lines, etc. attached that can break. Usually about 5 inches is enough but judge for yourself. All you need is enough to get it out. Carefully move the brake lines out of the way to help get the mount out. The mount will most likely be in two pieces and should come out pretty easily. Watch out for hydraulic fluid that may be leaking out of the broken mount.
Raise subframe back into place and put a jack stand underneath it so you have time to mate new mount to bracket as some jacks will leak down slowly.
Installation is basically reverse of removal. The order of installation is important because going in the wrong order makes it much more difficult to line it all up.
The new mount is held into the bracket with a large nut that must be installed and tightened down before it is put back in.
Lower the subframe and twist the mount/bracket assembly into place. This will take some finesse but will go in. Get the stud on the mount into the hole on the subframe.
Raise the subframe back up with the jack and install the subframe front bolts about 25%. This realigns the subframe and provides some safety while still allowing flexibility.
Install the bracket upper bolts about 25%.
Install the bracket lower studs and tighten them in all the way.
Finish tightening the bracket upper bolts (37 ft. lbs.).
Install the support bar over the stud and then install its bolt (37 ft. lbs.).
Install the nuts onto the studs of the bracket (37 ft. lbs.).
Install the mount to subframe nut (52 ft. lbs.). The mount/bracket should now be fully bolted down.
Fully tighten the subframe rear bolts and then the subframe front bolts (141 ft. lbs.).
Replace the level sensor connecting rods.
Put wheels back on and lower the car. Make sure to torque your wheels correctly (100 ft. lbs.). :)
Full sized pictures at the link below
http://photobucket.com/Seville_Mount_Replacement

Thanks for viewing and I hope this helps out. I will be happy to answer any questions although I have only done this procedure on my personal car and don't have knowledge of other models or years. Thanks.

cadi509
09-06-11, 01:59 PM
Great write up! Am I reading correctly you have over 2million posts?

Domino1968
09-06-11, 10:14 PM
Nice write up!:thumbsup: Thanks for sharing!

Submariner409
09-07-11, 01:14 PM
Excellent post. Thanks for the time and work.

jvc220
09-11-11, 11:40 AM
Great write up! Am I reading correctly you have over 2million posts?

Thanks! I have no idea why my post count is that high. I noticed it before but I figured it would correct itself.

The Gold
09-11-11, 11:33 PM
Thanks JVC for an excellent contribution.

jvc220
09-13-11, 10:51 AM
Thanks to everyone for your kind words. :)

00 Deville
04-12-13, 06:44 PM
Nice write up... step by step was spot on for the 00-05 Deville also.

I didn't have the -"E8 internal star socket – 1/4” drive" but a 12 point 1/4" wrench was a perfect fit to remove/install the 2 lower mounting bracket studs that thread into the block in step 8. The 00-05 Deville also had enough room to hand start the top two 15mm mounting bracket bolts from the top once the radiator hose was repositioned to the side.

ahmaduhhs
05-09-13, 10:10 PM
Hello fellas, would this directions work for a 2003 Cadillac Seville STS?

Ranger
05-12-13, 09:41 PM
Yes.

ahmaduhhs
05-12-13, 11:39 PM
Great, also does any one know what the right GM part number is for the front motor mount for a 2003 STS?


Yes.

Ranger
05-17-13, 10:06 PM
25696073

ahmaduhhs
05-18-13, 12:40 PM
Ty sir


Great, also does any one know what the right GM part number is for the front motor mount for a 2003 STS?

ahmaduhhs
05-22-13, 11:19 AM
Would this work:

http://www.amazon.com/DEA-A5235-Front-Motor-Mount/dp/B001FFQLAC/ref=wl_it_dp_o_pC_S_nC?ie=UTF8&colid=380WIPDYAHM7G&coliid=IX1R8AQK4XWYE#productDetails


25696073

cajunboy
07-02-13, 11:44 PM
Awesome write up. I will be attempting this soon. I am also changing out radiator. So it seems that it will give me more room. Is there any way to do it without messing with the sub frame.

ahmaduhhs
07-08-13, 10:09 AM
I am now in a home without access to a drive-way, any idea how much a local mechanic would charge for this? I already bought the part. I am now in Indiana vs. NJ.

Ranger
07-08-13, 10:10 PM
Why not call a local mechanic and get an estimate?

ahmaduhhs
07-15-13, 06:54 AM
Will do, thx!


Why not call a local mechanic and get an estimate?

chillitelesco
07-18-13, 04:15 AM
i am getting conflicting part numbers for this part,,,i need the front motor mount for a 98 sts and now i am confused by the motor mount and the tranny mount,,,i need the motor mount do you know the part number for my year i am getting these numbers,,Anchor 2896 Front Right Mount (Fits: STS),,,,
DEA/TTPA A5235 Engine Mount Front (Fits: STS),,,,,,,,,,these are listed on ebay and am confused one has what looks like a bracket on it and the other doesnt,,,can you help please,,,,,just need that front motor mount

ahmaduhhs
07-18-13, 01:28 PM
This is what i bought:
http://www.amazon.com/gp/product/B001FFQLAC/ref=oh_details_o07_s00_i01?ie=UTF8&psc=1

i am getting conflicting part numbers for this part,,,i need the front motor mount for a 98 sts and now i am confused by the motor mount and the tranny mount,,,i need the motor mount do you know the part number for my year i am getting these numbers,,Anchor 2896 Front Right Mount (Fits: STS),,,,
DEA/TTPA A5235 Engine Mount Front (Fits: STS),,,,,,,,,,these are listed on ebay and am confused one has what looks like a bracket on it and the other doesnt,,,can you help please,,,,,just need that front motor mount