: Bluetooth phone - doesn't ring



06 STS
08-26-11, 12:56 PM
I am sure this has been asked. But I haven't seen anything about it. So if possible - point me in the right direction.

I have an 06 STS. I bought it 1 1/2 yrs ago. I don't drive it much. But what I did notice is when I sync my phone. Incoming calls lower the radio volume. Is there a way for the system to ring? Everytime I have an incoming call, I think I am having a problem with my car.

Thanks for any help you can provide!

EChas3
08-27-11, 01:00 AM
Your phone should ring. The car doesn't.

mckellyb
08-27-11, 02:27 PM
Yeah, the car's audio system doesn't 'ring', it merely mutes whatever you had on the 'radio'.

I learned this, yesterday, with my computer case in the trunk. Someone called me on my personal phone, which was back there, and it took me a few seconds to check why Science Friday had gone silent.

nathanjax
08-27-11, 02:40 PM
The stereo in my 05 rings with my iPhone and my iPhone rings as well.

EChas3
08-27-11, 03:02 PM
The stereo in my 05 rings with my iPhone and my iPhone rings as well.

Is it connected via Aux?
Do you get your Ringtones?

I just get the green phone softkey. That or the VR steering wheel button answer the call.

nathanjax
08-27-11, 03:06 PM
Connected via bluetooth. Yes my personal ringtone goes through the system. My phone looks like a normal call coming in and rings, but my navi screen shows the number calling, plays my ringtone, and I have the 2 buttons on the screen (answer and something else)

06 STS
08-27-11, 08:10 PM
Interesting - it seems some ring and some don't. I ask this question because my mother-in-laws Buick plays the ring tone through the bluetooth system. So she does hear a ringing. I don't believe it plays the same ring tone as what is on her phone. I then wonder two things.

1) Maybe my 06 needs a firmware upgrade?
2) could it be the ringer I have choosen on my phone? I believe I have just the standard ringtones that came with my blackberry. Maybe I need a to try other ringtones and see if they play through the system.

Anyone else have any thoughts?

Thanks!

nathanjax
08-27-11, 08:21 PM
I don't think it would have anything to do with the ringtone. I will confirm this later tonight. I would think maybe more the phone?

No idea about the firmware though. I'll look to see what mine has tonight as well...

EChas3
08-27-11, 08:59 PM
I've got the firmware upgeade & LG phones. Some iPhone users report a noise upon connection - trade-off? I suspect a phone's call connection protocol determines support for this feature.

nathanjax
08-27-11, 09:42 PM
Some iPhone users report a noise upon connection

Man I hate that noise... It doesn't happen on every call, but is sure scares the crap outta me when it happens. It's like a high-pitched buzzing noise...

nathanjax
08-28-11, 02:41 PM
Well, it doesn't matter my ringtone, but I forgot to look at my firmware. I know when I hit configure, I have my settings right there, so it should be the latest...

chazglenn3
08-29-11, 03:27 PM
Mine doesn't ring through the stereo either...I'm using a Sprint HTC Evo 4G phone. I have the latest firmware installed.

EChas3
08-29-11, 10:21 PM
Those with trouble... make sure you have the latest phone firmware. Others? What you have is what you got.

carter's_sts
08-30-11, 02:17 AM
Do you guys have this happen sometimes, but not all the time?

Phone rings, stereo audio mutes. Answer the call, and then the stereo audio comes back on (along with the phone audio) and you can't control anything - volume and all buttons are frozen. Then hang up and back to normal. I end up calling a lot of people back. It's highly annoying. Latest phone firmware (actually have had 3 phones and they all did it) and latest Nav. firmware.

AllWheelEric
08-30-11, 11:45 AM
Phone rings, stereo audio mutes. Answer the call, and then the stereo audio comes back on (along with the phone audio) and you can't control anything - volume and all buttons are frozen. Then hang up and back to normal.
Yes, this happens sometimes. I don't believe there is a fix.

06 STS
09-01-11, 05:08 PM
I can't say this has happened to me. I have had it where the radio doesn't mute when answering the phone. This has happened a time or two. But I haven't really driven the car that often. Last year I drove it for the winter. Planning the same this year.

ddalder
09-02-11, 07:45 PM
I have a 2008 but the navigation radio is from a 2010. Mine mutes when I get a call and the ringtones come through the stereo speakers. My phone is an iPhone4. I do get that horrible buzz frequently (but for some reason, less often than I used to). There is an information bulletin from GM on this (which I obtained from an authorized GM electronics service centre). They bulletin claims the problem is with the phone, not the radio and dealers should not replace the radio for this problem.