: Limo progress....



turbojimmy
08-16-11, 09:32 PM
I got a lot done this afternoon.

My A/C part arrived. This proves once again that you can find ANYTHING on the Internet. I popped in the part number off the old solenoid and BAM! 2 of them popped up on eBay:

http://turbojimmy.4t.com/1994_limo_new_ac_valve.jpg

The prices ranged from $70 to $382 (yes, $382) on the 'net. I went with the $70 eBay one. Works great.

Just like my '96 limo, the rear a/c on this thing works awesome. The front, factory system sucks. The blower goes like hell but there's no air coming out the vents. It's frustrating. It's still a bit low on refrigerant, but it's working decent enough for now.

The cooling fans aren't working right either. One runs when the a/c pressure reaches 250 PSI, but that's it. Gotta troubleshoot that. There are two coach-builder installed fans that I need to rig up too.

While running the rear a/c on high fan during the refrigerant charging process, the tiny wire feeding the rear fuse panel got hot. Real hot. I fixed it thusly:

http://turbojimmy.4t.com/1994_limo_power_supply-1.jpg

80 amp fuse and 4 gauge wiring. That should do it. All the lights flicker just like my '96. A new alternator fixed the '96, I guess a new one is in order for this car.

Last, the headliner "mood lights" were half burned out and dim. I replaced them with LEDs.

http://turbojimmy.4t.com/1994_limo_old_and_new_lights.jpg

http://turbojimmy.4t.com/1994_limo_new_headliner_lights.jpg

Tomorrow I'm gonna use my new 3M eraser (clone) to grind off what's left of the broken decklid emblem. I like the shaved look back there.

MoistCabbage
08-17-11, 12:43 AM
I like how the mood lighting turned out.


Tomorrow I'm gonna use my new 3M eraser (clone) to grind off what's left of the broken decklid emblem. WOO HOO, swirl mark city. Tell you what, When the car's done, I'll come over and buff it for free, if you chauffeur me back home in it. :devilheh:

turbojimmy
08-17-11, 08:43 AM
I like how the mood lighting turned out.

WOO HOO, swirl mark city. Tell you what, When the car's done, I'll come over and buff it for free, if you chauffeur me back home in it. :devilheh:

Deal!

I was hoping the moon lighting would be brighter. It's really hard to light up the inside of a black car. At least my '96 had courtesy lamps above the middle doors. This one has that old-school Ford pickup dome light instead. I searched the web for something that has a similar footprint w/ LEDs but didn't come up with anything. The one thing I like about that is the map lights on each side. The lens is all yellowed, though, so it looks crappy. I'm going to do the courtesy lamps in LEDs anyway, that helps a lot.

I had to yank that Caddy badge off the back. It looks like someone stuck it on there with kindergarten paste. It was all globbed on and oozing through the script. The remnants of the original badge need "erased'.

I'm going to wire up the aux fans today. I don't like that I have only one, stock fan running. Federal has been really cool about advising me on this thing, despite the fact they manufactured the car 14 years ago. They suggested removing the failed electronic fan control (they don't make them anymore) and simply wiring the cooling fans into the high pressure switch for the A/C.

The car is making its debut this weekend when I go to Woodward, PA to pick up my GF's son and friends at skateboarding camp. I want it to be as functional as possible...

turbojimmy
08-17-11, 08:57 AM
Oh yeah - I forgot the best part. It passed emissions inspection yesterday! I screwed up the whole line with my pre-OBD-II vehicle. The technician didn't know what to do with it. She was fishing around under the dash for the OBD-II plug when another guy came over and helped her out. They had to drag out the tail pipe sniffer. I was pleased because I didn't do anything to the engine at all. Not even the air cleaner (which is pretty dirty, by the way). Looking at the CarFax and based on the way the hot engine smelled after my trip home (if you've ever started and run a car that's been sitting a long time you know what I mean), I don't think the car has been registered or on a public road in years. 7,000 miles were put on it in the past 10 or 11 years. It doesn't look like it had been titled since 2010. All I did was drive it off of the previous owner's lawn and 180 miles home. Yeah, it ran crappy at first but it's since cleared up.