: Check Engine and Trac Control Lights on



GoFlyers
08-15-11, 09:55 AM
I have a 2005 STS rear wheel drive with a V8 Northstar.

Today while driving to work on the expressway (doing ~78 mph) the check engine and trac control lights came on and the car wouldn't go over 900 RPM. I just dropped it off at the nearest repair shop for an evaluation but I am totally baffled at what could be wrong and why it would have shut down like that.

I found some old thread about 03 CTS's having similar issues and the suggested fix was a wire harness and clean/replace the throttle body... really?
I would be shocked if my throttle body/engine was that dirty. I had it cleaned out by the dealership under 20k miles ago and I use Lucas injection cleaner at least once a month.

I will report back once I get some information and the codes.

GoFlyers30
08-15-11, 10:59 AM
Ok, the initial word back is that there are too many codes (~10) being displayed at once. It is also now not showing any fuel in the car (gage reading empty) even tho there is ~1/2 a tank. Starts every time but idles very rough and only 900 RPM's. Zero response to pushing on the accelerator.

Before this happened this morning there were no idiot lights displayed at all.

donniesd
08-15-11, 05:19 PM
Sounds like your car went into limp mode to protect itself.


Cant to much to help without codes.

EChas3
08-15-11, 08:16 PM
Did the shop you found know Cadillacs? Many independents wouldn't have the correct reader & know-how.

valjan1
08-15-11, 09:09 PM
I have a sts4 4.6l and i have the same issue with it the engine sudently goes to iddle and not takin his gas so i put it in neutral shut the motor and start it again and it is ok . that problem happen with no warning and it is intermittent .

EChas3
08-16-11, 10:01 PM
I had a similar issue just sfter buying my car. The dealer replaced the gas pedal before finding a TSB about faults in the wiring/connection to the Throttle-body.

GoFlyers30
08-31-11, 10:22 PM
Car is back working now...
what I was told is that the wire harness shorted out causing the electronics in the throttle body and the computer to also fry. Ended replacing all three, so not the inexpensive and quick fix I was hoping for.

On the bright side, my old throttle body was clean as hell! So the Lucas injection cleaner seemed to do its job.

Dj Brady
09-01-11, 12:36 AM
On the bright side, my old throttle body was clean as hell! So the Lucas injection cleaner seemed to do its job.

glad to hear your throttle body was clean, but it's not because of the injection cleaner. the Throttle Body is "upstream" of the injectors. The lucas would treat the injectors and everything downstream, i/e; injectors, valves, piston head, etc.