: ODB Reader Problems



donniesd
08-05-11, 11:17 AM
When ever i plug it in my 2007 Cadillac STS, It puts the car in limp mode and causes me to have a P0700 code, Service Brake Assist, Service Stability Control.
I have taken care to stealership where one of my best friends work and nothing being pulled from the TCM. Its just that, every time i use your reader this happens. As soon as i unplug it the service displays go away and it goes out of limp mode. And i can start stop about 5 times and the CEL goes away or i can clear it then remove the reader it goes away. I can mimic this any way i want to. every hour, every 15min. every other day. I have not tried another reader yet.

Is this normal for Cadillac. I dont have any problems with me 06 Z71 Chevy Truck.

Using OBDLink OBD2 Scan Tool Kit with Bluetooth from scantool.net



Fault log report generated by Torque for Android
=================================================


Vehicle Manufacturer: Unknown
Vehicle Calibration ID: Not present

Current Fault Log
------------------
P0700: Transmission Control System (MIL Request)


Historic Fault Log
------------------
ECU reports no historic faults

End of report.

ddalder
08-05-11, 12:44 PM
Does your truck have RPO codes HP2 or MW7?

You need a reader manufactured for use on a CAN Bus network to read the STS. My guess is that yours isn't.

donniesd
08-05-11, 12:47 PM
Does your truck have RPO codes HP2 or MW7?

I will check when i get home.


You need a reader manufactured for use on a CAN Bus network to read the STS. My guess is that yours isn't.

Reader is

Supports all legislated OBD protocols:
ISO15765-4 (CAN)
ISO14230-4 (Keyword Protocol 2000)
ISO9141-2 (Asian, European, Chrysler vehicles)
J1850 VPW (GM vehicles)
J1850 PWM (Ford vehicles)

ddalder
08-05-11, 12:58 PM
My guess is still that there's some type of compatibility problem. You can reproduce the problem every time you plug your device in, yet your friend at the dealership has no difficulty. Your truck may or may not use the GMLAN bus. This was a transition year for those vehicles. If yours is the classic body style it won't have the GMLAN bus whereas if it is the new body style it will. Your reader may be working fine with the older Class 2 serial data standards. Have you contacted the manufacturer of your reader? There may be a known problem or software upgrade. I have a Tech2 myself and am not familiar with the product you use.

donniesd
08-05-11, 06:04 PM
If yours is the classic body style it won't have the GMLAN bus whereas if it is the new body style it will.
Yes i have the Classic Body Style.


Have you contacted the manufacturer of your reader? There may be a known problem or software upgrade.
Yes. They gave me some trouble shooter ideas. It has a 90 Day Warranty.

caddyfat2
08-05-11, 07:22 PM
[QUOTE=donniesd;2674192]Yes i have the Classic Body Style.


What is the classic body style? I thought ALL CADILLAC's have a classic body style.:smilewide:

ddalder
08-05-11, 07:46 PM
With the classic body style it provides more support for my theory that the problem is with the scanner and not the STS. Hopefully you'll get it all sorted out.

donniesd
08-05-11, 09:32 PM
What is the classic body style? I thought ALL CADILLAC's have a classic body style.:smilewide:lol my truck....haha