: anyone here with this problem?



esved
08-04-11, 03:20 AM
Hi all, I have a 07 ESV and recently in the past few month a problem developed where when I try to start the truck, seems as if the alarm is doing an ignition kill (the engine wont turn but all electricals function properly). Checked the battery and it is healthy (optima), but seems no electricity going to the starter. This latest episode got towed to the dealer but as I'm being unlatched from the flatbed the engine started!! But the check engine light stayed on. Left it at the dealer (they saw the problem) for a week and last I heard they couldnt find any faults but they know something is wrong. I asked them so what happens if they cant find whats wrong, what I got was "well just drive it until it happens again" which means I'll be stuck soon somewhere with a truck that wont start. Anyone here had this issue before? It'll do this ignition kill thing every other week, but leave it alone for about 20min to 1 hour and it'll start again but with a check engine light that stays on for about 3 days, during which the transmission will stay in "limp" mode and wont shift, but after 3days everything will be back to normal till the next time. Help!!! Its like I have to cross my fingers everytime I'm going to start the truck hoping it'll turn!!!

MrHolland
08-04-11, 05:36 AM
That doesn’t sound like very much fun. Unfortunately I’ve never heard of this. I wouldn’t accept my truck unless the service dept has remedied the problem and I would also request a loaner, preferably a Cadillac, until the problem has been properly and completely addressed. There is a Cadillac Customer Service Rep here that can probably help you with this matter. Good luck and keep us posted.

hcvone
08-04-11, 10:08 AM
Had a customer that had something like you describe, it turned out to be his ignition switch, it was acting if the key being used was a fake and prevented the truck from starting causing an alarm issue cutting power

esved
08-04-11, 10:48 AM
Thanks for the replies. I will let the dealer know about this possibility (hope they will take the advice). Hope it gets fixed since I have the factory extended warranty. What can I do if the dealer just calls it quits and wants to just have me take my truck home? Take it to another dealer or can I actually refuse to pick it up?

Cadillac Cust Svc
08-04-11, 12:46 PM
esved,

I am sorry to hear that you are experiencing this issue. I can’t say what would happen if you would refuse to pick up your vehicle. I would like to get our Customer Assistance team involved with this issue to see if they would be able to assist with finding the issue. Could you please send me your full name, address, VIN, phone number and current mileage?

Thank you,

Elizabeth, Cadillac Customer Service

esved
08-04-11, 12:59 PM
Hi Elizabeth, do you have an email address where I can give you the detail info? thanks

Cadillac Cust Svc
08-04-11, 04:20 PM
esved,

My e-mail is socialmedia@gm.com. Please put ATTN Elizabeth when you send the e-mail.

Thank you,

Elizabeth, Cadillac Customer Service

esved
08-04-11, 07:21 PM
Alright!!! Just got a call from the dealer and said they found the issue!!! A short in the transmission harness?? Hope this solves all issues!! Thanks for all the help!!

hannity
08-04-11, 10:07 PM
Alright!!! Just got a call from the dealer and said they found the issue!!! A short in the transmission harness?? Hope this solves all issues!! Thanks for all the help!!

I know the anxiety of having a truck that you love and pay for that gives you issues. It is annoying and frustrating. I felt every bit of your pain when I read your opening post in this topic. Now that they have found the problem I am happy for you.:cool:

esved
08-05-11, 01:38 AM
Issues are one thing, but to have the dealer tell you that they cant find the fault and to just pick it up and wait for it to happen again is definitely something else...... I'm still kind of crossing my fingers but I'm going to be optimistic on this!!! Will keep y'all posted....