: Tape player click incessantly?



OffThaHorseCEO
07-31-11, 02:12 PM
i posted this how to on the other allante forums i frequent, i'll copy and paste here

This is a fix for a tape player that clicks and will not play your tape. This causes issues because if you try to play a tape, it will click until you can somehow force the tape out, the stop/eject button will not work correctly in this situation. Due to that issue, you will not be able to listen to your AM/FM radio until you get the tape to stop clicking. The cause of this issue is usually a stretched cassette belt. The belt slips which the unit interprets as too much resistance which to the unit means end of tape. so it goes into a flip loop. here are my copy/pasted instructions on how i fixed this issue.


I ordered replacement belts for my Allante cassette unit using this information: http://allante.us/cgi-bin/yabb/YaBB.pl?num=1037287161

unfortunately that post didnt give any information on HOW to actually replace the belt (well it did, but its been about 9 years so the info is gone)

I went into this blindly, made it more complicated than it should have been, but ultimately learned alot and fixed my cassette unit.

Unfortunately i didnt think to start taking pictures until i had the unit apart and the belt replaced, i do have a few pics of reassembly though. Hopefully this will help, i will try to use the pictures i took as i was assembling, to show how to disassemble

Firstly, in case you forget how the belt was routed heres a crappy diagram
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110417_131135.jpg

Follow the instructions on Allante Source to remove the DIC then remove the cassette unit from the DIC: http://www.allantesource.com/bosespeak.htm

Once the tape unit is out flip it face down so you see this:

http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110416_000815.jpg
Remove the screws pointed to in red and remove the plate from the back of the unit. There is a zip tie holding a cable to the metal backplate, and it got in my way so i cut the zip tie so I could put the metal plate aside. Also its a good idea to seperate the bulb from the metal bracket and lay the metal bracket aside.

Once you remove the backplate and bracket, you will see this (which i will call the "black plastic assembly"):
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110416_000153.jpg

FIRST, remove the two screws indicated by the blue dots, remove the small shiny metal piece it holds and put it aside
NEXT, remove the c clip indicated by the green dot which is holding the dark metal piece down, Be careful removing this clip, mine flew across the room and i was lucky to find it. Remove the metal piece the clip was holding down
LASTLy, remove each screw indicated by the red dots, one is UNDER the dark metal piece you removed, i forgot to put this screw back, but it hasnt affected anything so far.
There are some red and blue wires routed along the top of the black plastic assembly you are about to remove, if you can deroute those, it will make removal much easier. Also, there is another zip tie holding all the wires together near where they connect. If you can cut this zip tie carefully, it will make the rest of the job much easier as well...


Carefully lift the black plastic assembly up and away from the cassette mechanism, it will not come fully off unless you disconnect the wires. It is NOT necessary to disconnect wires.

At this point, you will have access to the belt. The motor does not need to come off.
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110414_003226.jpg
Heres a view of the belt and motor from an angle
Remove and replace the belt, in my case, the original belt still fit snugly, but had streched alot. the new belt will be very tight.

Now you can start to put everything together. i originally was very worried about lining everything up properly and things jamming, so i tinkered. I ended up breaking something and discovered i didnt have to tinker anyway. The system pretty much lines itself up except for one major piece.
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110415_233940.jpg
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110415_234138.jpg
You MUST make sure that as youre reinstalling the black plastic assembly, that the metal piece indicated in red, goes into a slot in the black plastic assembly (green arrow) AND the slot in the white plastic piece (blue arrow)

After you make sure the black plastic assembly is snugly in place, you can reinstall the screws indicated by the red dots. Next put the dark grey metal piece and c clip back (green dot).

http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110416_000153.jpg
Lastly reinstall the shiny metal piece making sure it is installed as shown
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110415_234422.jpg
http://i6.photobucket.com/albums/y205/Offthahorseceo/IMG_20110415_234514.jpg
You should now put the metal backplate back on,dont forget to reattach the light bulb to the small metal braket.

Make sure all the connectors are plugged in and reinstall the tape unit into the DIC....

DONE!

heres a vid of my successful test after replacing the belt

http://www.youtube.com/watch?v=yKKoAW87JMw
Good luck and feel free to post any questions.