: Air Suspension Problems



Mark Ohio
07-29-11, 01:10 PM
Has anyone here had a 'service air suspension' message? If yes, would like to know if a majority replaced the sensor and it fixed the problem.

torched10
07-31-11, 03:53 PM
yup--had did it on my2003--- first check to make sure its not the fuse-if not, listen to see if you hear the relay click--if you hear the click its the compressor.I bought mine on line from Arnott--installed it--works fine now.Dealer wanted 1200 bucks--mine was like 250

bstiffmanofsteel
07-31-11, 06:19 PM
After my truck was rear ended, the sensor went which caused the compressor to kick on too often til it blew out...

Mark Ohio
08-02-11, 09:28 AM
Did you start the engine to listen for it or just turn the key on?

icejava
08-02-11, 05:42 PM
Hey Mark,
I'm currently having the same issue with "Service Suspension System" on my dash. Anyways, the way I checked to see if its the Air compressor is to release the air from the shock. First, make sure ignition is off. Then, There is a small air hose connected to each shock with a clip. I just release it and the air comes rushing out. Then I turn the ignition to ON. You should hear a click then a "air compressor pumping" sound.

On mine, my air compressor is working fine. So I haven't figure out what the issue is. Anyways, it only happened after I installed my new predator tune... which is weird.

audioatg
08-12-11, 03:19 PM
Have you had some one scan the code. I am sure its the air level pressure relief sensor. Its in the area were the compressor is. One either the sensor is bad and is killing the compressor. Or two the wires to that sensor are cut smashed chaffed so on.

Escalade90
11-24-13, 11:03 PM
Is the pressure relief sensor the box attached to the compressor?