: 09 ext model Nav problem



audioatg
07-26-11, 07:45 PM
Hello I am new to this site. Hope that some one could help me out. I have a 2009 ext Escalade with the Navigation radio and XM.
When you are one the nav map you can see the NAV traffic option. When I hit this all it says is XMNavtraffic loading data. And nothing after that. It just sits at that screen and does not change. I am up to date on my XM service and XMtraffic service.

My questions are is this a XM problem. A radio/nav unit problem. Do I just dont have an updated map CD( witch I am checking into). Everything else works. Onstar the NAv map shows my location. Just when I hit the traffic is does nothing but show the loading data screen.

CadX6
07-26-11, 09:49 PM
The nav disk has no connection to the traffic display, other than providing the actual nav display. If you're absolutely sure you have an active subscription to XM NavTraffic, (its completely separate from your XM Radio subscription) probably your only alternative is to call XM. If you end up doing that - you have my sympathy - they are the worst company to deal with that I have ever encountered. I had the same problem as you - with the display constantly saying "updating". Turned up it was their screw-up with my subscription. I'm actually thinking of cancelling my traffic subscription - it's useless here in Chicago. They quit reporting traffic on the one Expressway I used regularly and the coverage otherwise is only on the major Interstates and has big gaps.
(sorry for the rant - you just touched a nerve :mad2:)

audioatg
07-26-11, 10:06 PM
Thanks for the response, I have tried to contact XM about with no luck. Its like talking to the wall. How did you go about getting it repaired if you did. Also I am trying to understand the traffic thing. Is it really for only main roads that are high lighted on the map coverage map on the web site. Or is there part of their web site to list what roads it works on.

audioatg
07-26-11, 10:07 PM
O and yes again I am paid fully up to date on both my XM radio and XM traffic. I dont have the trail plan.

CadX6
07-26-11, 10:53 PM
I'm not an expert on the subject, but it has been my observation in driving around the state of Illinois, the traffic function only shows Interstate highways - & even that has huge gaps. We have an Interstate (I355) between I290 & I88 where the traffic only displays for N/B traffic & not S/B. Very irritating since 90% of the time I'm going S/B. I've never seen anything for any surface streets or even thru highways that aren't Interstates.
I suppose you could take it back to the dealer (I assume you're still under warranty since my 09 is) and tell him "it's not working - fix it". It could conceivably be a hardware problem or maybe he's got a secret number into XM. Good luck........