: my sts just stopped running and now it won't start



smelt85
07-24-11, 11:05 AM
I got a 2006 sts and I was driving it fine and then the engine just shuts off. ( no warning lights, it was not over-heating or anything) It was running great, then just stopped. It is like someone just flipped the off switch or something, and now it won't start. It turns over but won't start.

ddgm
07-24-11, 12:50 PM
Sometimes it's the little things that one tends to overlook, like how much gas is in the tank, although the low fuel warnings should have been present.
Unfortunately, with so many modules and electronics in the vehicle, about the only thing a DIYer can do is check for fuel and spark. Likely will have to have it diagnosed with a Tech II (Dealership). Good luck.

Doug

dkozloski
07-24-11, 03:33 PM
I was going to say, out of gas.

smelt85
07-24-11, 07:35 PM
thanks for the reply, I think you are right. I am guessing it might be something simple too. I just filled up the tank with gas the day before, so I know it has plenty of gas. Right now it is still in the shop, they've had it for two days. They called me today to tell me, that they still can't figure out the problem. They say my car has a spark, it is getting fuel. So they are still trying to figure out why it just shut off and now won't start. I think it has to be electronic related. I just don't know what. because like I said before, It was running perfect before this happend. No warning or anything, just shuts off. I still got power, from the battery, it tries to turn over,just wont start. and I take very good care of the car. I have never had a problem with it until now.

turnerbend
07-25-11, 01:04 AM
Check fuel pump relay fuse.

EChas3
07-27-11, 10:12 PM
If they say it has fuel and spark but won't start, take it somewhere else. They don't know what they are doing.

If the plugs spark and there's fuel and air in the cylinders, somethng should happen. (In may not run smooth but it will at least make noise.)

Is it a V6? Their cam chains can have issues. But still, it should at least backfire. I'd wager it's crank position sensor if it really does have fuel pressure.

smelt85
08-01-11, 06:38 PM
It is the timing chain, that is what made it stop running. At least, that is what the dealership i took it too said. so now i am just waiting for them to fix it and put everything back together.