: Am I the only one who has problems with the windshield nut caps?



cbloveday
07-15-11, 11:45 AM
Seems to have been alot of build whinning going on lately. So, I do not want to feel left out and thought I could help at the same time. It will fill my void to feel accepted and part of something. :)

Anyway, I am consistently loosing the cap that covers the wiper arm nut.
First it was the passenger side and I found it the water trough thingy. The cap is a snap on
type cap and one of the prongs was broken. No problem had it replaced free of charge. I could not determine if this was caused when I had the car worked on by a non GM shop or not. So now I watch them closely and low and behold,
The driver side is gone. :hmm: Poof! like it vanished. Must have been wind shear huh? :bonkers:

Anyway, I ordered several caps. The driver and passenger side are universal. Part # 10341324 for $6.26 bucks at the dealer.

I though about wrenching the bolt into a different orientation to see if that would resolve the problem but figured,
I never had the wipers off and it may create a over tighten situation.

So, has this occurred with anyone else and if so, you got the part number now.

There, I feel like I have contributed something.

e6t
07-15-11, 12:55 PM
could not duplicate

M5eater
07-15-11, 01:34 PM
could not duplicate
ROFL

must have gone something like this

Customer complained- Windshield nut cover


cover not found-- could not duplicate.

Razorecko
07-15-11, 01:47 PM
Same thing Curtis, I lost mine also. I figure a couple dabs of general silicone will hold it down....I'm honestly so glad to have an '09 because it seems like the first year V's have the highest build quality. Who would have figured the first year production would be so solid.

BLEWBYUWIT6.2
07-15-11, 02:20 PM
the one on the driver side on my car had been missing since i got it....i bought a new one and put it on about a month or two ago....but since you say yours flew off im goin to check it today when i get off....i thought someone my have taken it off and forgot to put it back on....

cbloveday
07-15-11, 02:34 PM
Good to know I'm not going crazy and this is happening to others. Raz, I like that silicone idea and will do that the next time I notice one mssing. BTW, I usuallytake my car to the spray wash in between hand washes (mainly to rid the wheels of break dust). It occurred to me that when washing the windshield, I may have inadvertently loosened the cap. However, I have been very wary of this for months and still have been confronted with "the case of the missing nut caps" to solve.

KevinR70
07-15-11, 10:19 PM
Yep. Passenger side on my 09. Thanks for the part #.

cbloveday
07-15-11, 10:50 PM
My pleasure.

tedcmiller
07-16-11, 08:50 PM
Sorry, no problem here. Both my covers are present even after two years. My CTS-V is a 2009. However, I don't really believe that the year of the car has anything to do with nut cover longevity.

mpouls1
07-16-11, 09:38 PM
I've been missing my driver side ever since you pointed it out to me back at Byron last year. Would have never even noticed. Figured it wasn't even worth it, just going to pop off again. Kind of like the "clicking dilemma." Pretty cheap so guess I will order some. Maybe another member can figure out how to keep them on. It seems as if the tabs are brittle/thin and break. Cheap fix, thx.

cbloveday
07-16-11, 10:41 PM
Sorry, no problem here. Both my covers are present even after two years. My CTS-V is a 2009. However, I don't really believe that the year of the car has anything to do with nut cover longevity.

Mine is a 2009 as well.

cbloveday
07-16-11, 10:42 PM
I've been missing my driver side ever since you pointed it out to me back at Byron last year. Would have never even noticed. Figured it wasn't even worth it, just going to pop off again. Kind of like the "clicking dilemma." Pretty cheap so guess I will order some. Maybe another member can figure out how to keep them on. It seems as if the tabs are brittle/thin and break. Cheap fix, thx.

Glad to help Mike. Hope your doing well.

garfin
07-17-11, 01:30 AM
Funny you should mention this! Both covers on mine disappeared - one last summer and then the second one this spring. Both were replaced under warranty by two different dealers with no questions asked.

Best regards,

Elie

Mystical_Ice
07-17-11, 11:32 AM
used superglue :/