: windshield wipers stuck please help



cadillac kevin
07-14-11, 11:33 PM
my wipers are stuck a couple inches above the hood line. I guess I bumped the switch sometime when I was in the car and now they are stuck up. messing with the wiper control does nothing. I dont even hear the motor trying to work. the wiper fuse is ok.
the delay feature on the wipers never worked, nor did the wiper fluid, so my guess is the switch went out but I want to make sure before I go out and spring for the new switch. anybody have any ideas on what could be wrong?

mjs182004
07-14-11, 11:51 PM
loose wire maybe under the hood?

outsider
07-15-11, 11:34 AM
the wiper/washer functionality on all of these cars is super buggy and probably the #1 problem people have.

I've replaced my switch twice due to stuff similar to what you're seeing. Others have replaced their pump, motor, etc...with little success.

Most people have said replacing the circuit board will fix the problems in most cases...I haven't tried it.

The-Dullahan
07-15-11, 05:03 PM
Mine did that once. I replaced the Relay and never had the problem again.

cadillac kevin
07-20-11, 08:11 AM
which relay is that? I dont have my underside dash covering to reference by