: Nav/Infotainment system defaults



rdhinatlanta
06-30-11, 09:18 AM
A few weeks ago my 2010 SRX nav/tainment display started operating different than normal: 1) on startup, screen now defaults to weather screen - attempts new download each time ( I do not subscribe to weather); and, 2) default city for nav destination is Washington, D.C. versus Atlanta. Cannot find where to change the default settings back. Any clues?

stevec5375
06-30-11, 10:15 AM
The Nav/Info system in the SRX is a POS. I had the same problems as you and reprogramming it didn't work the first time so they ended up having to replace the entire unit! Now, the nav default destination city is back to Washington, D.C. instead of my local city. I have basically given up on it since I use the Nav so little.

Smokin' SRX
06-30-11, 12:16 PM
RDHINATLANTA, Welcome aboard! Lotsa knowledge and support here. I saved a bundle!

I know Steve and a few others had this problem, but got it easily fixed. Most only needed a quick software re-flash, others had the unit totally replaced. Usually is a permanent solution.
Talk to dealer first. 99% of us have a nice working unit. If I paid for it, I'd want such a nice feature to work.

Steve seldom tells us how he really feels! LOL But he's entitled to be frustrated. However, if I were he, I'd try asking the GM service rep, (Elizabeth) on this main Forum board*, for assistance if the dealer won't help. Cure seems to work eventually. Even if ya don't use it, why stay frustrated? Your money, your call.

Peace,

SS

* click upper left box "Cadillac Forum" on main screen. then scroll down a little to GM Customer Service Rep header. Make your post.

allgm
06-30-11, 01:33 PM
I have the same problem reflashed twice. Been waiting for a new nav unit. Been on order for two weeks now. Will call dealer next week for update.

stevec5375
06-30-11, 02:24 PM
I have the same problem reflashed twice. Been waiting for a new nav unit. Been on order for two weeks now. Will call dealer next week for update.

I hope your new Nav unit fixes the problem once and for all. Mine is acting up again even though it was replaced and worked fine for a while.

stevec5375
06-30-11, 02:29 PM
RDHINATLANTA, Welcome aboard! Lotsa knowledge and support here. I saved a bundle!

I know Steve and a few others had this problem, but got it easily fixed. Most only needed a quick software re-flash, others had the unit totally replaced. Usually is a permanent solution.
Talk to dealer first. 99% of us have a nice working unit. If I paid for it, I'd want such a nice feature to work.

Steve seldom tells us how he really feels! LOL But he's entitled to be frustrated. However, if I were he, I'd try asking the GM service rep, (Elizabeth) on this main Forum board*, for assistance if the dealer won't help. Cure seems to work eventually. Even if ya don't use it, why stay frustrated? Your money, your call.

Peace,

SS

* click upper left box "Cadillac Forum" on main screen. then scroll down a little to GM Customer Service Rep header. Make your post.

You should read what I posted regarding politics in other forums. This is mild in comparison.

Basically what gripes me about this SRX is that I bought it in Feb 2009 and only have a little over 9,000 miles on it. It's had to go to the shop way too many times to be so new. I know "LIFE IS SHORT" and it sure as hell is too short to have to put up with all this crap. This is my last ever Cadillac because I don't think it lives up to all the hype.

allgm
06-30-11, 05:01 PM
I might be thinking like steve. I don't really use it . How much of the dash is removed to replace it. Might end up with rattles and pry marks. You can only remove those spring clips so many times.

stevec5375
06-30-11, 05:22 PM
I might be thinking like steve. I don't really use it . How much of the dash is removed to replace it. Might end up with rattles and pry marks. You can only remove those spring clips so many times.

I was concerned about that very thing Delores. I was ASSURED by the dealer that these cars were very modular and they didn't have to pull the dash to replace the Nav unit. So far, so good. I have not heard one rattle as a result of the replacement. But, as a precaution, I would bring this up to the service people just so they know it's a BIG DEAL to you. That might get some extra care taken on the replacement.

smiley47
07-01-11, 02:18 PM
[QUOTE=stevec5375;2640816]You should read what I posted regarding politics in other forums. This is mild in comparison.

Basically what gripes me about this SRX is that I bought it in Feb 2009 and only have a little over 9,000 miles on it. It's had to go to the shop way too many times to be so new. I know "LIFE IS SHORT" and it sure as hell is too short to have to put up with all this crap. This is my last ever Cadillac because I don't think it lives up to all the hype.

Steve, don't you mean Feb 2010? BTW, I had the same "Washington D.C." default destination problem. That problem and a nav system issue where upon start up I had a nav "caution warning screen" that required clicking OK as well as the radio did not start up on the station that was playing when the vehicle was last turned off. Now that was wierd. A software update earlier this week seems to have fixed both issues.

stevec5375
07-01-11, 02:34 PM
[QUOTE=stevec5375;2640816]You should read what I posted regarding politics in other forums. This is mild in comparison.

Basically what gripes me about this SRX is that I bought it in Feb 2009 and only have a little over 9,000 miles on it. It's had to go to the shop way too many times to be so new. I know "LIFE IS SHORT" and it sure as hell is too short to have to put up with all this crap. This is my last ever Cadillac because I don't think it lives up to all the hype.

Steve, don't you mean Feb 2010? BTW, I had the same "Washington D.C." default destination problem. That problem and a nav system issue where upon start up I had a nav "caution warning screen" that required clicking OK as well as the radio did not start up on the station that was playing when the vehicle was last turned off. Now that was wierd. A software update earlier this week seems to have fixed both issues.

Yes, I meant 2010. Thanks for catching that typo.

I have had both the problems that you state. They replaced the Nav Unit and that seemed to fix it. Now I get that Nav "caution warning screen" every time and the default destination is back to Washington D.C.

Let's hope your "fix" lasts a lot longer than mine.

smiley47
07-01-11, 02:47 PM
[QUOTE=smiley47;2641718]

Yes, I meant 2010. Thanks for catching that typo.

I have had both the problems that you state. They replaced the Nav Unit and that seemed to fix it. Now I get that Nav "caution warning screen" every time and the default destination is back to Washington D.C.

Let's hope your "fix" lasts a lot longer than mine.

My service advisor did say it was a "new" software update so you might ask about it the next time you go to the stealership. Mine is working fine so far.

Smokin' SRX
07-02-11, 04:18 PM
Gotta admit no matter how great my Dealer was (and they are) I would be pissed if I had to bring my new car in 5-10 times in first year. I guess I would think Lemon, or not buy another. Hard to say till it happens. But everyone deserves a second chance and a third if I really think they have a new approach!

Good luck to Delores. Consider Steve's advice re: dealer. Hope you fare better with your replacement Nav than he did.

SS