: crazy stuff going on with my truck!!! any info is much appreciated!



blkEsc
06-28-11, 08:53 PM
First my truck started having the problem where the keyless entry remote start and tms stop working and intermittent back up sensor light on dash. I had to disconnect the battery positive cable and then after letting it sit and reconnected it and everything started working again! thought it was fixed.. Two weeks later I noticed that my clock reset twice on the nav not the analog clock. Then all of a sudden every now and then my stabiltrack light service traction control light came on but after driving it I can hit the tracking control button and it goes off and works again no problem.. Today it did it again and my check engine light came on also. I can't get either of them off now but i'm sure it will be tomorrow after the truck sits. Does anyone know what this could be and has anyone ever had this problem before? This is driving me nuts and the last thing I wanna do is go to the stealership.

hcvone
06-29-11, 09:13 AM
If you have the stock battery replace it with a good battery, it sounds from what you are saying that it maybe the battery

darkknight1999
06-29-11, 08:14 PM
Yeah I would agree with hcvone, I would bet the battery is going bad.

2007caddy
06-29-11, 08:44 PM
Time for dual...I'm so happy those days are long gone

blkEsc
06-29-11, 10:08 PM
what is dual?? new symptom I tried to use my remote start the lock works and lights go to go on for the remote start and it doesnt start. new battery going in friday and crossing my fingers this fixes all problems!!

bstiffmanofsteel
06-29-11, 10:57 PM
what is dual??
http://www.cadillacforums.com/forums/cadillac-escalade-ext-esv-forum-2007/130849-second-battery.html

blkEsc
06-30-11, 11:07 AM
Do you think that will fox my problem?? Is this all due to a crappy battery? Did you have the same issues with yours and did this fix it? Thanks

bstiffmanofsteel
06-30-11, 08:01 PM
Check out this thread!
http://www.cadillacforums.com/forums/cadillac-escalade-ext-esv-forum-2007/232306-just-bought-used-07-escalade-yesterday.html

blkEsc
07-05-11, 08:44 AM
So I put a high output battery in and my airbag light is still on don't have a scanner to clear it. Is there any other way to clear it? My traction control still goes on intermittently. No more check engine lift or anything else. Any ideas??

darhef
07-05-11, 10:35 AM
Sounds like you may have some legit sensor issues perhaps?