: 2007 Escalade Seat A/C Plug Burn Out. Need Advice Please.



OC PLAYER
06-22-11, 11:44 AM
Hello fellow caddy drivers,

Here is a photo of the burned out plug under the passenger seat. This is the seat AC plug. How do I fix this? Picture is kind of crappy. Camera would not focus.

Have 3 other issues.

1: The fabric covering the A pillar inside the auto is bubbling apart. Fix please?

2: Once in a while I get all the electronics going wacky on me. (stability control error messages, car will not shift, etc.) What is causing this? The car has a new battery. Could it be the battery cables?

3: I have an intermittant check engine light. Onstar (before I cancelled them) told me I have a dirty mass air flow sensor? Can I clean this myself?

Car has 120K.

Thanks

fivepix
06-22-11, 04:10 PM
Not sure about 1 or 3 but for 2 - Battery/Electronics - someone on here had similar issues they had the ground wire replaced to solved the problem.

http://www.cadillacforums.com/forums/cadillac-escalade-ext-esv-forum-2007/232306-just-bought-used-07-escalade-yesterday-2.html

blkEsc
06-22-11, 07:03 PM
thats's my exact problem!! my plug looks the same. please help us!!! lol

OC PLAYER
06-23-11, 10:00 AM
thanks, I will swap out the battery cables.

Mha
06-26-11, 10:57 AM
Does your ac seat just not work at all? I had my ac seat on yesterday and it didnt seam to be cooling. I stopped using it for a few hours the tryed it out again and it started to work again butseamed to take twice as long as it did before to cool. I think it getting ready to go or something. I want to take it in since im still under bumper2bumper warranty untill august of this year but think if it still kind of works they wont fix it. I going to look at it today. Is the ac and heated seats the same plug? If the ac doesnt work should the heated part work? Thanks

NorthernHillbilly
10-29-11, 07:34 PM
Anyone know if we can just order this plug? I fixed the red/white wire's issues, then the black one down and one over did the same thing....are my seats shorted out, or is this just a GM thing!?!

OC PLAYER
10-30-11, 01:38 AM
You gotta buy the whole harness, about $100. But you need to remove the seat to install it. I ghetto rigged my plug.

NorthernHillbilly
10-30-11, 04:56 AM
****ing GM. it's a Delphi 15326924 Plug. Approx cost, $2.00, plus $0.20 for each crimp on connector you'd like.....Here's the odd part. max rating for this plug, as spec'd by Dlephi, 20-25Amp MAX. Why does GM have a 30A fuse in the dash then....

NorthernHillbilly
11-01-11, 09:37 PM
So, GM does sell the plug separate, it's about $8.00 for the plug, and $7.00 for each individual pin. I had to butcher my old plug to get it off..un pinned the old one, replaced 4 of the pins, plugged it back in, and seats work again...

Note: I thought i'd be a hero and flow solder into all the connectors, to make a better connection, and on about 4 of em, i flowed the solder in, and it ran down, and stopped the tab on the connector from opening, not allowing the blade on the motorola module to slide in...:( don't be a hero!

nick lewis
01-09-12, 05:26 PM
Hello fellow caddy drivers,

Here is a photo of the burned out plug under the passenger seat. This is the seat AC plug. How do I fix this? Picture is kind of crappy. Camera would not focus.

Have 3 other issues.

1: The fabric covering the A pillar inside the auto is bubbling apart. Fix please?

2: Once in a while I get all the electronics going wacky on me. (stability control error messages, car will not shift, etc.) What is causing this? The car has a new battery. Could it be the battery cables?

3: I have an intermittant check engine light. Onstar (before I cancelled them) told me I have a dirty mass air flow sensor? Can I clean this myself?

Car has 120K.

Thanks

Hi have the same on my 07 esv- the connector burns out and you can buy them and redo the wires as talked about in the post. I have not fixed mine yet as I cannot get the 15326110 connector out of the Motorola module. The dealer wanted over $700 to fix P&L. Mine failed after I remote started and not get in the car within the 5 minute period. The amount of current to the seats and the heated rear screen along with the blowers on full blast over load the ground.

For the rest the stabiltrack and engine light issues are all part of the fuel and management system. I had a throttle body service done at the main stealer, they forgot to attach the vacuum line on the intake casing a lean condition. this will create the service traction control/stabilitrac errors as the fuel and engine power get reduced in a loss of traction condition so if the banks are too lean errors this will disengage the stabiltrac. (also causes the remote start to deactivate) Best option is to service the throttle body / injectors and check all the vacuum lines. Once I connected my vacuum the light went off. Also if you have air ride front struts that are leaking you can also get the stabiltrack/traction errors as the management system cannot stiffen up the struts correctly.
Closing note, these are sensitive cars and have way to many sensors that are there to ensure a smooth ride but often break or burn out. I can say every 2 months something breaks or needs attention so I spend a lot of time researching the parts before going to a dealer.

Ghost Deany
02-08-12, 09:42 PM
****ing GM. it's a Delphi 15326924 Plug. Approx cost, $2.00, plus $0.20 for each crimp on connector you'd like.....Here's the odd part. max rating for this plug, as spec'd by Dlephi, 20-25Amp MAX. Why does GM have a 30A fuse in the dash then....


Does anyone have any idea why this is the case? Why is there a 30A fuse for it?

SouthernCaddy
02-09-12, 06:00 PM
Same guy that did the heated washer fluid designed this. Let them know they will give you some money and remove the plug so you dont have A/C seats anymore.... :(