: "system problem"



Moondoggie
06-14-11, 08:50 PM
I disconnected the ECU on my '89 STS 4.5 liter in anticipation of swapping it out for a junkyard brain to try and resolve the timing still advancing while the DIC reads "TIMING MODE" with the ALDL A and B jumped issue I then reconnected the brain as it laid loose on the passenger seat floor. The car still runs fine, I drove it to the car wash this afternoon but the DIC is reading "system problem". I can't get that to clear to read any codes. What now? Any experts out there?

dennis93coupe
06-17-11, 02:54 PM
Have you tried disconnecting the battery for a few minutes and reconnecting? If nothing happens disconnect again, check your harness connections and you might try removing the prom from ECU cleaning terminals. Put it back together and try that. Do the same with the BCM, remove the PROM and clean terminals, reinstall. Always disconnect battery before removing either of these. Check for poor grounds. And I know you checked all the fuses. Keep in mind that the BCM determines what is displayed, not the ECU. The ECU and BCM communicate, but the BCM actually sends the information.

Moondoggie
06-22-11, 07:02 PM
I disconnected the neg bat terminal and replaced the ECU with the junkyard unit. The car runs fine but DIC reads SYSTEM PROBLEM, same as before. So it's not the ECU.

dennis93coupe
06-23-11, 02:24 AM
Have you pulled codes to see if you have any? You might be looking for a BCM. I don't know much about STS, so I would suggest going to that forum.

Moondoggie
06-25-11, 06:11 PM
I can't clear "SYSTEM PROBLEM" to read any codes. There were no ECU codes earlier, anyway.

dennis93coupe
06-25-11, 06:22 PM
Have you tried the STS forum? Might want to give them a try, your problem I would say is more in line with the complete system instead of just an engine problem. I can't say you have a ECU problem (engine control unit) this sounds more like a BCM (body control module). Do you have a FSM? Good idea to get one or try this....

http://www.alldatadiy.com/

STS_Seville_Hunter
06-26-11, 06:03 AM
According to the FSM its set because of a BCM code being set, for diagnosis it says check sections b334 (loss of ecm data), can you check codes? We can go furthur with it if so ( I have FSM sitting) infront of me

STS_Seville_Hunter
06-26-11, 06:07 AM
Also it lists B335 and says this in bold pring "BCM Code B335 indicateds a loss of data communication between the CCDIC (Climate control/ Driver Information Center) and the BCM. When this event occurs, the CCDIC will display "SYSTEM PROBLEM" until the condition is corrected

Moondoggie
06-26-11, 09:50 AM
I'm going to the Dana Point St Regis Concours today, will check to see if anything is disconnected early this week. Thanks for the info, guys.