: 2007 Rear liftgate doesn't work.



nvr2fst
06-03-11, 03:59 PM
Hello Everyone,
I have an '07 escalade and on a road trip this past week the automatic rear liftgate doesnt work at all. Nothing. If i hold the button on the key the lights flast but nothing happens and no noises. (motor doesnt even try to unlatch or lift) If i hold the button on the outside of the gate it unlatches but doesnt lift (you have to lift manually). The button for closing doesnt do anything..
Anyone know if there is a fuse for the liftgate assist or any other ideas?

Thanks for your help. little things like this really get to me. :banghead:

LeftLane
06-03-11, 04:15 PM
make sure the switch in the upper center console with the sun roof didn't get turned off. Its a rocker switch and one side disable the hatch from opening.

nvr2fst
06-03-11, 04:19 PM
make sure the switch in the upper center console with the sun roof didn't get turned off. Its a rocker switch and one side disable the hatch from opening.

That was it! wow I've never noticed that switch before and would have never known to look for it!

Thanks

Cadillac Cust Svc
06-13-11, 04:48 PM
Nvr2fst,

I am glad to hear that was the issue and nothing major went wrong. If you have any other issues, please message me.

Thank you!

Elizabeth, Cadillac Customer Service

Sclimos
02-02-12, 09:48 PM
2007 Escaclde ESV liftgate stopped working. I've changed the motor, checked fuses and Lgm module fuse with no luck. The overhead switch is on the on position so that's not it. I took it to a shop and they said they could'nt figure it out. They ran power to the motor and it works. Once you try to push the button the lock motor works on the liftgate itself but it stops from coming down or going up. It's really starting to drive me crazy. HEEEElP!!!!

----------

How long does it take to get an answer on this site?

MrHolland
02-02-12, 09:51 PM
Have you or anyone else tested the switch that disables that feature??