: Twilight Sentinel

05-20-11, 05:14 PM
My headlights are on the entire time the car is running...no matter the lightness or darkness outside.

I assume it is the sensor in the dash, but my question is...how do you get to it? If you have to remove the dash, how do you go about doing that?

Also, what does something like that cost?

05-20-11, 06:11 PM
I'll assume this is the 95. The light sensor is under the defrost vent in the dash. It may have become detached and fallen down the vent, making the car think it is dark out all the time. You just grab the edge of the defrost grille and pull up. The other possibility is that you have DRLs. Run the VIN on the Compnine VIN checker and see if you have the RPO for daytime running lights. OR, someone could have fitted your car with aftermarket DRLs. Those are the three options I can come up with. Cost? Free, if you figure it out yourself.

05-20-11, 06:50 PM
jay, if i remember last time i took mine out. i think theres 2 screws holding that vent in place. could be wrong though

05-20-11, 07:56 PM
Could be, I know the B body ones pull straight out. I can check my parts car tomorrow...

05-20-11, 08:49 PM
i think its 2 7mm screws

05-20-11, 09:08 PM
the screws are under the vent so no need to remove them
unless your removing the entire dash, just lift it out

I think Jay is on to it , there is a plastic cup that holds the
sensor that comes unglued especially down there in the
Alabama heat, if its not unglued , and the sensor took a dump
just send me your address via e mail Ill send you out one
on the house, I have a bunch of them

05-23-11, 12:28 PM
Great. I will check that this evening and let y'all know.