: Squeaks and creeks with Eibach Springs on V-Coupe



RichP_CTSV
04-30-11, 04:05 PM
Has anyone else noticed this issue? Its noticeable when going slow over a bump, tight turn in a parking lot, etc. I haven't noticed it much at road speeds. I know the D3 springs have had noise issues, but I haven't heard anyone complain about the eibachs yet.

rednumbers
04-30-11, 05:11 PM
hate to hear that, I was going to switch my D3 when the eibach sedan springs are released.


It seems that I have some unusual noises but I wouldn't describe it as squeeking or creeking.
I am hearing clunking when I drive at slow speeds over less than perfect roads. The wierd part is that its only on the right side. I am thinking something is loose. Had the installed take everything a part but the noise is still there.

Does anybody know the V suspension well and maybe can give me a tip of what can be loose or installed wrong. Car drives fine but just that clunking noises on the right side.

D3 mentioned that I should check the nut on top of the strut inside the engine compartment after you take off the Mag sensors. I did but it seems that nut does not tighten. Is it suppose too?

musclesbmf
05-01-11, 09:34 AM
Make sure you are checking the correct nut. Remove electrical sensor, then remove the long metal connector that the sensor attaches to, and then the nut is under that. Yes, that tightens and loosens. Need a very deep well socket to reach it.

Mark

RichP_CTSV
05-01-11, 12:50 PM
Mark,
You are the spring - swap expert here, does your friends car with the eibachs exhibit any of the same sounds/clunks/etc that the D3s have?

I am thinking of snipping the front springs a little if I end up having to remove them to sleeve them to fix the noise. The front is a little high with the eibachs.

baabootoo
05-01-11, 01:49 PM
Oh, oh. Here we go again........ :(

rednumbers
05-01-11, 08:32 PM
so I took off the sensor, but I am not sure how to get the actual long metal peice out. It does not seem to want to move

any tips


Make sure you are checking the correct nut. Remove electrical sensor, then remove the long metal connector that the sensor attaches to, and then the nut is under that. Yes, that tightens and loosens. Need a very deep well socket to reach it.

Mark

e6t
05-01-11, 09:00 PM
My factory suspension squeaks and creaks.

musclesbmf
05-01-11, 10:42 PM
I'm far from being an expert, but I have done the swap at least 6 times. KILLR-V's car has no squeaks or creaks from the suspension and they've been installed for close to 6 weeks I think and he has a 30+ minute commute everyday to work, do he is putting some miles on it.
As for the piece not turning, they over tightened it... it doesn't need to be that tight. You have the electrical connection to the long electrical conductor (basically looks like a long nut with a receptacle on top), and then the nut under that. You have to get that electrical conductor off to gain access to the nut. It should spin right off. Under that you will see the threads from the shock top and the nut holding it together.

I would definitely trim the front spring. Todd's rear was lower until we trimmed 1/4 coil from front spring. His measurements are now 26 5/8 front, and 27 1/8 rear for a 1/2 rake which is about perfect.

Mark