: Need Help with Nav Unit!



Mattah
04-24-11, 01:26 AM
So I am looking to purchase a 07 escalade from a local independent dealer. It has 73,xxx miles on it. I personally know the pervious owner so I have no doubt of abuse. Its fully loaded with power steps.

Well when I went to look at it today, the Navigation screen would not turn on. The dealer owner said he had it detailed and then it quit working.... More things are wrong... No OnStar, Back up camera obviously does not work, rear entertainment, park assist too! Could it be as easy as a blown fuse?

BTW when I hold down the power button for the nav/radio. For maybe 3 secs it makes a beep. Don't know why...

Im going back to the dealer Monday to look over it again. Kinda hesitant to buy it now.

What else should I look out for?

One more thing wrong, the front windshield wiper fluid works up front but the rear does not. The guy said it might have a separate reservoir, does it? I dont think it does my 07 denali does not.

Thanks guys!

the cadillac man
04-24-11, 01:35 AM
good possibility it is a fuse blowed by the way it sounds i would check all of the fuses before doing anything else

the cadillac man
04-24-11, 01:38 AM
and as for the washer fluid it might be low but check the hoses mine was bad on my 03 when i got it didn't find until the next week after i got it but i replaced them worked ever since

Mattah
04-24-11, 12:50 PM
good to know, thanks.

I did a search on here, seems that two other guys have had the same problem but they never responded back with a solution.

Mha
04-24-11, 01:12 PM
And there still asking what they were asking before when It all worked? Use that to get a lower price and if ends up needing a new nav ebay has a lot of them, aftermarket and oem. And some of newer 2010 ones with usb.

2007caddy
04-24-11, 03:48 PM
Unplug the battery for about 2 hours

Mattah
04-24-11, 03:51 PM
no the suv is priced well. 28.5k but he did that because it needs new tires. He has not reduce the price of the car yet because he thinks he can get the nav to work.

Mattah
04-26-11, 12:25 AM
Hey is it normal when the navi/radio doesn't work you cannot put in a cd? It almost as if there is this metal piece blocking it...

anyone seen or heard of this?

fivepix
04-26-11, 09:31 AM
@Mattah to insert a CD you have to hit the button above the CD Eject button (It has an icon that looks like a stack of CD's) than a message will display on the Nav that says you can insert the disc.

Cadillac Cust Svc
04-28-11, 01:11 PM
I would agree with fivepix. You have to press the button that looks like a stack of CDs in order to insert a cd into the system. If you get a chance to take a look at the owners manual you can find this information on page 280. I hope this helps you.

Jeff Morris, Cadillac Customer Service