: VERY UNHAPPY with W4M ported supercharger, snout, TB and 2.55 upper



musclesbmf
04-23-11, 08:24 PM
This is not a bashing thread. So please don't make it out to be one. But I am disappointed.

So, I received the ported pieces via UPS on Monday and waited all week to install my additional "100 HP" mod. Everything looked good when received and the solid isolator that was installed took out all the shaft rattle (knew this by spinning the supercharger pulley).
I took everything apart today and transferred all sensors, injectors etc to the new blower. Installed the new blower by following Lingenfelter's step by step instructions. They have a nice write up with torque specs and everything.
Got everything reinstalled and attached and started the car up. Sounded great and decided to take it for a test drive just to make sure everything was good (without getting on it until properly tuned). I had no more driven 50 yards when I heard the worst belt screeching noise ever. I immediately turned around and pulled back into my garage and shut the car down. Popped the hood and smoke was coming out the front grill (not good). When I opened the hood, the supercharger pulley had turned grey and it was smoking... hmmmmmm. I tried to start the car again and it would not start. Seemed like something was dragging it down. I decided to remove the supercharger belt and test the outcome. The car started right up so I knew everything was installed properly etc (as the charger base and snout came assembled). I shut the car down and then tried to rotate the supercharger pulley. IT won't turn. It is seized.... UNBELIEVABLE!!!! The screeching noise was the belt being pulled across that pulley and it not spinning... also the reason I saw some melted belt on other parts of the motor.
So now I have a car that has a non-rotating supercharger on it. HORRIBLE!!! Car runs fine without the supercharger belt installed. There's a nice wasted day and money.
Tried calling Jesse but of course it is Saturday and the day before Easter so I knew that was a shot in the dark.

Anyone??? Jesse???

I've always been a big fan of his stuff and supported him, but this is very disappointing.

Mark

Caddy Wagon
04-23-11, 09:03 PM
So is the snout or the supercharger causing it not to turn? Have you taken it apart to find the problem yet?

Mike TexaSS
04-23-11, 09:55 PM
Wow!

Cub Cadet
04-23-11, 10:35 PM
Why are these types of threads getting more and more frequent??? I am starting to wonder. I have not seen posts about other catastrophic events through other people.

e6t
04-23-11, 10:43 PM
Why are these types of threads getting more and more frequent??? I am starting to wonder. I have not seen posts about other catastrophic events through other people.

are they really "more and more frequent"? Also, without any dignosis at all, should this be considered truly a catastropic event?

musclesbmf
04-23-11, 10:45 PM
I hope to have a chance to pull it apart tomorrow, but being Easter that may be tough. Have some family stuff to do :-)
And let me say, the car falls on its face after 2000 RPM, but I'm thinking it's the tune as it is expecting a lot more air flow so there is too much fuel and it's just bogging down. And I'm referring to just normal driving when I drove up to the grocery store.
I wouldn't call this catastrophic at this point. Worst case I put my stock blower back on and get my $$ back and think about doing the lower instead. I've got my fingers crossed that when the appropriate parties see this thread it gets handled timely and effectively.

Mark

DrumStix
04-24-11, 12:24 AM
It's the tune.

Seriously though, did you switch out the entire blower or just the snout? You are going to make any power with the belt off and the rotors sitting there so don't bother trying. It's no the tune. It's a stationary rotor pack on a motor that may make 385-400 HP if the rotors weren't blocking the airflow.

Take it apart and try to spin the shaft will seeing what is preventing it from rotating.

GMX322V S/C
04-24-11, 12:40 AM
It sounds like the blower ingested something--the tolerances are so tight, tissue paper will jam it up. If the rotors can't be reversed, they'll probably have to come out--160 degrees of twist is a long way to go...

baabootoo
04-24-11, 12:55 AM
You said this ISN'T a bashing thread???????????? It most certainly is. Go complain to the person that did the work, like a normal person would. If you don't like his work, GO TO SOMEONE ELSE!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Real simple, isn't it? You can always file a BBB complaint too, right? The internet is NOT the place to complain. What if you messed up the install? How do you retract this then????????

TimmyC
04-24-11, 12:59 AM
Did you put oil in the new blower?

n0s4atu
04-24-11, 01:19 AM
... How do you retract this then????????

You come along with a subsequent post and say what happened. Most people tend to follow an entire thread and typically don't read the first post and move on.

This notion that you can't complain about something you spent a couple grand on is ridiculous. He stated facts; got new parts, installed new parts, new parts go boom. He didn't bash anyone, or say the stuff is junk and demand his money back. Personally, as a consumer I want to know the good AND the bad and how problems are resolved. Knowing both allows people to make the most informed decision possible when spending their hard earned money.

These aren't his first posts on the forum, which would call the thread into question, he's relating his experience and I (and I'm sure others) appreciate reading about it. Based on things I've read so far about wait4me, he doesn't seem shady, etc and I'm sure he'll handle it, but there's no reason someone can't vent.

jb7952
04-24-11, 02:28 AM
You come along with a subsequent post and say what happened. Most people tend to follow an entire thread and typically don't read the first post and move on.

This notion that you can't complain about something you spent a couple grand on is ridiculous. He stated facts; got new parts, installed new parts, new parts go boom. He didn't bash anyone, or say the stuff is junk and demand his money back. Personally, as a consumer I want to know the good AND the bad and how problems are resolved. Knowing both allows people to make the most informed decision possible when spending their hard earned money.

These aren't his first posts on the forum, which would call the thread into question, he's relating his experience and I (and I'm sure others) appreciate reading about it. Based on things I've read so far about wait4me, he doesn't seem shady, etc and I'm sure he'll handle it, but there's no reason someone can't vent.

100% agreed. Posts like this are good; We need to know the good and the bad as these things are worked out. There's no judgement in the post, only facts. I'm very interested to see what the issue is and how it's resolved, as I'm sure are many other people that plan on modifying our cars.

MReiland
04-24-11, 07:49 AM
Any chance its the isolator? If the blower worked fine before it and the snout should have spun freely, between the two is the solid isolator such that when installing it, it didn't slide all the way in and now has bound the snout and blower from spinning? I know in the past there were tolerancing issues on those.

Caddy Wagon
04-24-11, 08:52 AM
Did you put oil in the new blower?

That is a possibility, as well as the blower ingesting something and locking it up.

Somefun
04-24-11, 09:26 AM
I would pull it apart and check everything. I really don't see any of the parts being bad. I just got Jesse's 10" lower with bracket and its nice stuff that fit great. It was lacking instructions but hell I'm a guy I most likely won’t have read them anyways.....Make sure you look for marks on the rotors. Maybe the isolator was installed a little off? I know mine went in wrong and had to make sure it was straight. Good luck hope it all works out for you...

musclesbmf
04-24-11, 09:29 AM
It's the tune.

Seriously though, did you switch out the entire blower or just the snout? You are going to make any power with the belt off and the rotors sitting there so don't bother trying. It's no the tune. It's a stationary rotor pack on a motor that may make 385-400 HP if the rotors weren't blocking the airflow.

Take it apart and try to spin the shaft will seeing what is preventing it from rotating.

Exactly what I hope to do today.

Mark

musclesbmf
04-24-11, 09:31 AM
You said this ISN'T a bashing thread???????????? It most certainly is. Go complain to the person that did the work, like a normal person would. If you don't like his work, GO TO SOMEONE ELSE!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Real simple, isn't it? You can always file a BBB complaint too, right? The internet is NOT the place to complain. What if you messed up the install? How do you retract this then????????

Quote one thing I said that I bashed anyone? I stated my experience and disappointment, and even closed that I've been a big supporter. Thanks for your "great addition" to this post.

musclesbmf
04-24-11, 09:34 AM
Any chance its the isolator? If the blower worked fine before it and the snout should have spun freely, between the two is the solid isolator such that when installing it, it didn't slide all the way in and now has bound the snout and blower from spinning? I know in the past there were tolerancing issues on those.

Snout came installed on the blower already, so I hope it was installed correctly. The car ran at idle for a good 10 mins before driving down the road and then the screeching belt noise and no pulley spinning.

Mark

6speeder
04-24-11, 09:55 AM
Did the snout spin freely before install? I ask because when I put a 2.55 pulley on the stock snout IT WOULD NOT SPIN. My supercharger snout casting was not round, it was egg shaped and the out of round area was hitting the inside of the pulley. We removed the pulley and filed away about 1/8" of the offending material of the snout. Now it spins freely.

Gary Wells
04-24-11, 10:43 AM
Hope that everything works out for you on this issue, Mark.

dvandentop
04-24-11, 10:43 AM
will be following this one

e6t
04-24-11, 12:34 PM
Quote one thing I said that I bashed anyone? I stated my experience and disappointment, and even closed that I've been a big supporter. Thanks for your "great addition" to this post.


your situation sucks and I hope it works out... but no offense bro, this is a textbook example of a bashing thread. just because you qualified your thread by saying it wasnt bashing, doesnt negate the bash.

these threads come up often and its unfortunate... because they are "out there" and searchable by google. its sucks because you have no idea why you are having the problem and it could be something you did wrong or something simple.

if someone searches "w4m supercharger", your thread is the first thing that is returned. they may or may not read the entire thread to find out what happens, but at the end of the day, the thread is inflammatory and harsh.

http://lmgtfy.com/?q=w4m+supercharger

just sayin'...

Hope your issue turns out to be something simple!

DrumStix
04-24-11, 12:58 PM
I'm not seeing the bashing. He said he liked his interactions with w4m but that this part is not working at all and I can see why someone might freak out a bit. He is disappointed and looking for assistance and ideas. If he were bashing it would be against forum rules and I think Florian or LC would have tazed him by now.

How would you have gone about it? Not post at all? Just askin'

e6t
04-24-11, 01:14 PM
Look up the definition of bashing.

I'm not saying he is out of line, just that it is in fact bashing.

I would contact Jesse or at least figure out what is wrong... Hell, if I had installed all that stuff, I'd assume I did something wrong!

Plus, we've seen a few times that Jesse will fix the issue no matter who is at fault. I'd figure out where the problem lies before I blew someone up... In fact, I'm going though something MAJOR with my car right now and haven't said a word about it on here. Yet.

DrumStix
04-24-11, 01:24 PM
Seriously? Please quote the bashing.

While at it, look up the definition of nifkin.

e6t
04-24-11, 01:30 PM
Is what it is...

But I've got no dog in this hunt so I'll let you and yours carry on with your not bashing.

Good luck with accomplishing whatever it is that you are trying to accomplish...

n0s4atu
04-24-11, 01:31 PM
So now, people can only post positive experiences with vendors? We should never hear anything negative, or anything less than absolutely stellar? Doesn't seem like the best way to get the full story. I mean hell why stop there? Why not completely eliminate anyone posting about their experiences with a product and just let the vendors themselves just tell us how great they are?

If anyone Google's W4M supercharger, comes to this thread and only reads the first post, simply put they're a moron. Who does that?

I want the good, the bad and the ugly. More importantly in a thread like this one, I want to see how well the vendor responds and handles it. Nobody can deliver 100% defect free products, there are bound to be duds in a batch. So whether something simply failed or the OP goofed on the install, I want to know how the problem is solved.

Unless this type of problem becomes commonplace with a W4M mod, I highly doubt anyone is instantly scared off from buying and most likely if W4M delivers the customer service and responsiveness he seems to typically, I'd think a thread like this would go further to show that in good times or bad, he stands behind the quality of his product. Good customer service these days is in short supply and any vendor who steps up and comes through when something goes wrong is someone people should want to do business with.

Stating an experience that is less than 100% positive isn't bashing, it's real life. These things happen.

hulksdaddy
04-24-11, 01:33 PM
your situation sucks and I hope it works out... but no offense bro, this is a textbook example of a bashing thread. just because you qualified your thread by saying it wasnt bashing, doesnt negate the bash.

these threads come up often and its unfortunate... because they are "out there" and searchable by google. its sucks because you have no idea why you are having the problem and it could be something you did wrong or something simple.

if someone searches "w4m supercharger", your thread is the first thing that is returned. they may or may not read the entire thread to find out what happens, but at the end of the day, the thread is inflammatory and harsh.

http://lmgtfy.com/?q=w4m+supercharger

just sayin'...

Hope your issue turns out to be something simple!

I agree. Until you find out what was actually wrong, you need to have a mod change the title.

Florian
04-24-11, 01:33 PM
Talk to Jesse, then post.
We are closed.


F