: 2002 Deville completely died at 80 mph



soccer_eldorado
03-22-11, 10:21 PM
I was driving my 2002 and it died at freeway speed, I pulled over, couldn't restart, no dash lights, no power accessories, nothing works. Long story short, I bought new battery, and still nothing. The positive battery cable looked pretty corroded, but I didn't have anything out on the freeway to clean it off with. Do you guys think a corroded battery connection would cause the car to have absolutely no response from turning the ignition key?

maeng9981
03-22-11, 11:09 PM
Do you see blinking yellow SECURITY light when you open a door with key not in ignition?

jimsbox
03-23-11, 01:28 AM
Also, check for a broken ground strap from front right corner of engine (above the alternator) to the passenger side frame railbehind the headlight. I know that will keep them from starting, don't remember if it affects everything else or not. You can just jumper with a jumper cable from negative battery post to one of the engine lifting brackets or some bare unpainted metal on the engine.

jordan00escalade
03-23-11, 05:19 AM
double check your wires to your alternator. follow them to the battery and make sure all those cables are tight and secured. Then check your alternator.

soccer_eldorado
03-23-11, 10:37 AM
all the wires are good, I did a cleaning of the positive and negative battery cable, checked the alternator wires, all is good. Also, the security light is not flashing while I open the doors with the key out of the ignition. I did all of the above and nothing still happens. None of the power door locks, windows, seats, or radio works.

jimsbox
03-23-11, 03:41 PM
Did you use a jumper cable from the engine to the ground terminal of the battery as I suggested?

soccer_eldorado
03-23-11, 04:56 PM
Yes I did. I'm giving up on this one and letting a mechanic shop do the work. They went through all the fuses, checked the alternator, battery cables, tried jumping them as you said. They still haven't found the cause. In the morning, they are going to look at the ignition switch. Looks like a 1000 repair bill. I love cadillacs, but I have to say, I never had any problems in my Lincoln Town Car like I've had with the Cadillacs I've had. I think I might go trade the car in for a nice Cartier Town Car when all is said and done.

ThumperPup
03-23-11, 07:17 PM
most expensive fix i ever had in any of my Lincoln was when the Rack and Pinion and the Power Steering pump at the dealer cost 1700 total
used Engine for a 95 Lincoln Continental was 1600 for parts and labor used at the dealer
start cost me 340 at NTB and alternator from dealer cost me 450 after parts and labor

im really afraid to know what the other parts would cost to fix in the Cadillac lol not even going to look at the price for rack and pinion PS pump starter or alternator i know they are a lot higher then the Lincoln cost

i think my Lincolns where by far the most reliable vehicles i ever had

maeng9981
03-23-11, 09:05 PM
If your SECURITY light does not blink, I would think the car is not getting any power from the battery. Even when your ignition switch is bad, security light would still blink and RKE would work.

ThumperPup
03-23-11, 09:33 PM
if i had not already seen something hear posted about trying to Jump Directly from under the hood to the Positive and Negative try to give the car a little power or try to hook up and jump directly off the batter if there is no power at all then there is a short somewhere and it is possibly a ground issue