: Horrible ride quality in my 73 Eldorado convertible.



boywnder26
03-12-11, 08:44 AM
First of all let me say that I am new here so I hope I am posting in the right place...forgive me if not. I have a 1973 Eldorado convertible with just under 85,000 miles on it. The ride is horrible. Bumps in the roads jar, shock and even cause the car to loose traction at times. I have never experienced anything like this and I'm getting weary of even driving it down the street. New parts to include, cv axles, hub bearings, upper and lower ball joints, inner and outer tie rods and sleeves, steering dampener, rotors, calipers, shocks, ect, ect. Can anyone please help or recommend help in DFW? Thank you in advance.

carnut
03-12-11, 11:43 AM
Go to the basics. Tire pressure to specs printed on the door jamb? Rear level ride shocks inflated? Has a 4 wheel alignment been done to confirm the car is tracking straight?

boywnder26
03-15-11, 07:04 PM
Just wanted to say Thank You very much for that nugget of wisdom. Indeed the front tires were overinflated when last rotated. Funny how the simplest things can escape rationale. Granted these parts were replaced prior to this problem....it still helps to remember the basics. Thank you again.

johnny kannapo
03-15-11, 11:17 PM
A-frame bushings come to mind. You may want to inspect the frame rails in front of the rear wheels for rust out & can crack all the way around. There are bushings in the rear that will cause problems.

The car is going on 40 yrs old the bushed chassis parts especially the front A-frames & related parts like brake strut rods get some slop in them due to rubber cracked out will cause severe control issues.

Those cars had torsion springs so make sure they have proper mounts & function.

carnut
03-16-11, 01:32 AM
You're welcome!