: Unread/Read Threads Not Displaying Properly



Stingroo
03-11-11, 02:13 PM
I'm assuming this is a bug going on alongside the recent "changes", but I'll throw it out there.

Threads that I have already read, and especially threads where I was the last poster, are still showing up as "unread" when I navigate through the site. I tried clearing my cookies, restarting my browser, and even tried it in IE (Gaaaaaaaaaaaaaah), but no luck.

JimmyH
03-11-11, 02:25 PM
I am experiencing this as well.

drewsdeville
03-11-11, 02:27 PM
Funny, I had just the opposite problem yesterday. Somehow, everything on this site had shown up as "read". No clearing of browser cache, cookies, or any modifications.

JimmyH
03-11-11, 02:34 PM
now that I look at the forum indexes, everything before today is showing up as read. Sal must have marked everyone's posts as read.

Ranger
03-11-11, 11:40 PM
No problems here.

EDIT:
:hmm: What happened to the forum index at the bottom of each post? Now you have to go up to the "Cadillac Forum" button on the top left to move to another forum.

Submariner409
03-12-11, 11:34 AM
Read/unread - OK here - still appear as bold if not read.

???? Never been able to switch forums in a post. Always had to go to the "Cadillac Forums" tab(s).

ThumperPup
03-12-11, 02:22 PM
i can open up the Lounge Section and see it same as always what is unread to me and what is not unread to me
but if i open up the Seville Eldorado or any of the other ones in the past vehicle section of the forum
they all look read to me even if i have not read them

Ranger
03-12-11, 03:45 PM
Read/unread - OK here - still appear as bold if not read.

???? Never been able to switch forums in a post. Always had to go to the "Cadillac Forums" tab(s).

There used to be a box at the bottom of the thread which listed the forum you where in. If you clicked on that box a list would open a list of options, one of which was "Forums Home". It opened up the list that the Cadillac Forums tab does. Just made it a little faster to get there. That box is now gone. :noidea:

Lord Cadillac
03-13-11, 01:29 PM
Go here:
http://www.cadillacforums.com/forums/subscription.php?folderid=0

When I go there, I see discussions that I'm subscribed to - and if there are posts which I have not read yet, they're in bold. Is this not working for some people? It sounds to be like it's working for some and not others...

JimmyH
03-13-11, 10:44 PM
this is the link I use:

http://www.cadillacforums.com/forums/usercp.php

It used to only show threads (in bold) that had new posts. If you clicked on a thread, read all the new posts, and went back to this link, that thread would then be gone from the list entirely. It does not matter to me either way, because it is easy to distinguish bolded threads from ones that arent.

My point is that the new posts button http://www.cadillacforums.com/forums/images/buttons/firstnew.png does not work the way it used to.

For example; if I log on, and click on the new post button, it takes me to the first new post since the last time I logged on. Now say, after I leave that thread, and go on to something else, some one else makes a new post in that first thread. In my subscriptions, the thread will show up bold again, but clicking on the new posts button, will not take me to that post, it will still take me to the first post from when I first logged on.

Now, say I skip a couple threads with new posts, figuring I will read them the next time I log on. Well, those new posts (which used to remain as new posts until I actually view them) will be marked as read the next time I log on. This is the new condition I have a problem with. Because, unless I view EVERY SINGLE new post every time I log on, I am going to miss them, because they will all be marked as read the next time I log on, whether I see them or not. And now that I think of it, there are other forums that are like this, and always have been. It never really occurred to me, because this is the only forum I frequent.

RippyPartsDept
03-13-11, 11:50 PM
i use both the subscriptions (sal's post) and the settings/usercp (jimmy's post) links ... and both have been acting weird for a few days

either threads that are read are showing as not read (still bold - even if i'm the last post)
or threads that have new posts are not showing in bold in the subscriptions list or showing up at all in the settings/usercp view
(which makes sense since the forum should only put unread threads in that view)
also, sometimes my settings/usercp view will show me posts that are read and that view is only supposed to show threads with new posts
see screenshot below
http://img193.imageshack.us/img193/815/screenshotvjn.png

first noticed friday 3/11

RippyPartsDept
03-13-11, 11:57 PM
jimmy put a pretty good description on what's happening... although i think there might be even a little more that he's not noticing

for instance - take this screenshot... it is of the first page of 'new posts' ... it normally only shows posts that are in bold/unread (since any read posts would not be new) ... well it's showing posts now that aren't bold and aren't new
http://img193.imageshack.us/img193/815/screenshotvjn.png
never used to show those posts before... like now it's just showing the newest posts in order not remembering if they're new to me or not

Lord Cadillac
03-14-11, 12:33 AM
I've made some additional changes.. It may not be perfect, however. Let me know if it's bearable...

RippyPartsDept
03-14-11, 12:54 AM
i'll check back in tomorrow and report what i'm seeing

Stingroo
03-14-11, 09:26 AM
I don't use any of that. lol

It used to be, I click the lounge, see all the bolded threads, and say I click one and post in it. Upon returning to the lounge, it would be un-bolded and all the others would stay bold. Perfect.

I'd go lurk the RWD forum, maybe harass a person or two to post pictures of their car, offer a small tidbit of technical advice and leave. Upon heading back to the lounge I would still see the same unread threads in bold and the ones I posted in in regular typeface. Now, however, I see the thread that I'm already the last poster on still in bold, which makes me think that someone else posted, so I'll click it again and see that isn't the case, refresh the page, and it's still bold.

Also, I've experienced this on three computers now.

Ranger
03-14-11, 01:18 PM
Checked in this morning and had 2 pages of "unread" threads in Seville and Deville forums, 90% of which I had actually read. They went back to 3/11 and should not have gone past last night. :noidea:

Lord Cadillac
03-14-11, 02:49 PM
It may take some time for things to sort out again. I think it'll be okay now but keep reporting back.

Thank you...

JimmyH
03-14-11, 02:59 PM
so I guess you changed it back? It seems to be working just like it did before. Thanks Sal. I prefer read/unread working properly to all out speed. Regardless, i chipped into the kitty. If more folks did that, perhaps we would not be in this situation.

RippyPartsDept
03-14-11, 03:35 PM
yeah i'm noticing the forum acting 'normal' again

Lord Cadillac
03-14-11, 03:35 PM
Thank you, Jimmy.. I did change it back - but in a way that's less server intensive. So we should still see faster page loading (especially since this wasn't the only thing we changed) and better results in the new post areas...

Stingroo
03-24-11, 01:13 AM
Bump. This is still happening for me. Especially in the Southeast forum.

JimmyH
03-24-11, 03:52 PM
That's odd. It's working for me. Even in SE forum. Anything older than 3-12 is going to show as read since that is when Sal reset it. Did you try deleting your cookie and clearing cache?

RippyPartsDept
03-24-11, 03:56 PM
Yeah still working good for me... as far as i can tell

Stingroo
03-29-11, 09:49 AM
Really odd, this only appears to be happening in the regional forums. It takes two or three clicks or refreshes to get it to shut up about the non-existent new posts. I cleared my cache, and even tried setting all forums as read.

Small annoyance, I'm not too worried about it. I find it more odd than anything.