: coolant leak



Lewis Rolen
03-08-11, 05:33 PM
is it possible there is another hose down below the HCV that could be leaking? If so, I have taken all the stuff off to change HCV and there is no access below tht point without pulling the motor!

kaustein
03-15-11, 02:13 PM
there is a heater control valve behind the engine block and ahead of the firewall that leaks. Only $150 repair job!

catera00
03-16-11, 06:52 PM
I dont think so. What makes you think it isnt the HCV now that youve removed everything? Best thing to do would be to pick up a coolant pressure tester from Harbor Freight (If you have one in your town) and pressurize the system. You'll find your leak real quick. Plus you can return the pressure tester when youre done. They have a great return policy there. They dont care if you used it and changed your mind about keeping it.

http://www.harborfreight.com/catalogsearch/result?category=&q=coolant+pressure+tester

http://www.harborfreight.com/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/i/m/image_1498.jpg

Otherwise just replace the HCV cause thats probably the issue.

Lewis Rolen
03-20-11, 11:25 PM
If i pull the HCV it should be obvious where it's leaking from right, I can see the black hcv with three connectors coming off it, and I see nothing, water is pouring out as quick as it go's in,draining out right under the passengers side exhaust manifold cover..

retho78
03-21-11, 12:20 AM
Are you able to see the HCV leaking when you pour water into the reservoir tank? The HCV may look good from outside but most likely it is bad inside. Another guess is there a coolant pipe that connects behind the oil cooler area, there is the seal between pipe and block, that maybe be broken, hard to see without taking everything apart....but my best guess it is the HCV.

Lewis Rolen
03-23-11, 11:18 AM
I can touch every part of the HCV and it's not wet, I'm telling you, it's like I'm pouring water in the coolant tank and it's pouring right out under the exhaust manifold guard just like the two other guys posted in Mystery leak, it must be the inlet pipe that go's into the block, I will take it apart thisweekend, other than that, just replaced ECBtu and oil cooler, all code lights are off and runs great, just won't hold coolant!

retho78
03-23-11, 06:03 PM
when you replaced the oil cooler, did you mess with the thermostat too? I'm guessing that the thermostat might not be seated properly.

catera00
03-29-11, 06:42 PM
The solution: http://www.cadillacforums.com/forums/cadillac-catera-cimarron-forum/225774-coolant-leak-found.html