: Mirror-to-curb malfunction?



slow98cobra
02-20-11, 01:40 PM
Well i just recently bought my '04 cts-v with 34K on the odo and i'm fairly happy with it. The mirror-to-curb worked just fine when I bought it but now it isn't working properly. It goes down like it is supposed to in reverse then when I go forward it raises but doesn't stop at the right position. It continues to go all the way up to the limit of the mirror. It acts like it doesn't sense the stopping position and continues to the sky.

Has anyone else experienced this? If so, what did you do to fix the problem?

rand49er
02-20-11, 01:58 PM
This is a new one on me.

odla
02-20-11, 04:09 PM
have you tried to reset the position?

slow98cobra
02-20-11, 04:23 PM
Yea and unfortunately it didn't work.

ahahnu
02-20-11, 07:15 PM
Mine has never worked.

The Guns
02-20-11, 08:20 PM
I currently have this on an 06. it seems to be cold or wet weather related. I am also experiencing driver side mirror BS going on: the driver side mirror moves when I use the fob to unlock the car. it doesn't return to the correct position.

Because the mirror has to return to a position, I am guessing there is a position sensor on/in the motor pack. this sensor is being fooled somehow (or not read).

When I install my set of autodimming outside mirrors, I'll take a look at the motor packs. Probably this spring. anyone know who supplies the housing/motor pack for the car??

slow98cobra
02-20-11, 08:40 PM
Don't know who supplies them but I figured out a fix for mine.

Here is what I did(step by step):

1. Located my favorite beer - 6pk (Boulevard wheat for all who care:thumbsup:)
2. Popped the hood and disconnected the negative battery terminal
3. Opened said beer and started drinking one
4. After I finished the beer, reconnected battery terminal
5. Started the vehicle and set all of my memory options including the mirrors on Driver 1
6. Made sure my mirror switch is in the middle position(not designated driver or passenger):bouncy:
7. And to my amazement that was it

So what it needed was actually a position reset like stated above by odla but it only worked after I disconnected the battery for awhile. Also, make sure your mirror selector is in the middle not on driver or passenger side.

The Guns
02-20-11, 09:59 PM
Don't know who supplies them but I figured out a fix for mine.

Here is what I did(step by step):

1. Located my favorite beer - 6pk (Boulevard wheat for all who care:thumbsup:)
2. Popped the hood and disconnected the negative battery terminal
3. Opened said beer and started drinking one
4. After I finished the beer, reconnected battery terminal
5. Started the vehicle and set all of my memory options including the mirrors on Driver 1
6. Made sure my mirror switch is in the middle position(not designated driver or passenger):bouncy:
7. And to my amazement that was it



There must be a step missing: you only drank 1 of 6 beers.

slow98cobra
02-20-11, 11:32 PM
Had to take it around the block so I waited to drink those until I got to the job well done stage.:)

mstrjon32
02-21-11, 09:36 AM
When I install my set of autodimming outside mirrors, I'll take a look at the motor packs. Probably this spring. anyone know who supplies the housing/motor pack for the car??

Where did you find the auto-dimming outside mirrors? I didn't think they were an option for the CTS?

Gus_Mahn
02-21-11, 06:55 PM
Mine did the same thing, so I turned the feature off. Maybe I'll try to disconnect the battery. The auto down/up window feature will need to be reset after the battery gets disconnected.

The Guns
02-22-11, 08:05 PM
prototypes from a secret place...

kevm14
02-22-11, 08:17 PM
Yeah, they are right next to the prototype motor mounts that don't suck. Shame they didn't make production.