: New owner of a 98 Eldorado and need some advice



Timber Wolf
02-19-11, 03:51 AM
Hello Everyone,

Well I'm brand new to the 32V Northstar. I have always thought it would be great to own another Cadillac since my '82 Fleetwood HT4100. I picked up a beautiful Polo Green 98 Eldorado Base from an older man that my soon to be wife has known all her life. He had bought the car in 2001 with 30K and my future father-in-law has been his mechanic for it as well as his immaculate '79 Coupe Deville.

I purchased the car with 77,100 miles and it is in pristine condition. My future father-in-law actually talked me into buying the car and added that the previous owner had kept up on maintainance. Mostly little things (the worst being an oil pan gasket) but he is very particular about the maintainance of his cars and sold me the Eldorado because I'm quite the same. He had just replaced the spark plugs and the CA required smog shows that it passed with flying colors.

The previous owner swears it has never overheated and that he changed the coolant about 3 years back so I'll have that done as soon as I can. Now I'm hearing dexcool is great and dexcool is awful. Especially that consumer complaint website I came across where people just blamed Dexcool for ruining their engines. I'm really on the fence about what I should put in. I do like to change the coolant every year or so. Would dexcool be fine or would the green stuff be better? I did notice that northstarperformance.com recommends the plain ol green.

I'm starting to read some heart sinking stories about HG failures and how the 98 is really up there on the polls. But it seems like yearly or every other year coolant changes are really the only thing I can do? Is there any other preventative measures I can take? I really want it to last

I've noticed that my temp gauge runs just a hair over dead center when at operating temp. I've driven it 45 miles at a time on the highway several times and have done about 10 WOT's in 2nd gear and have noticed no fluctuations from dead center. But I have noticed that after the engine has been off for maybe an hour or two, when I start 'er back up the temp gauge hasn't gone down all that much. I have read of folks having their temp guage still reading something at morning start up but mine is stone cold in the morning. I'm hoping its just paranoia because the only other experience I have with temp gauges is my 2000 madza B3000 (Ford Ranger cousin) and it'll be cool to cold fairly quick after shut off. Does the northstar engine cool slowly or is this something to be worried about?

And should I run regular mineral or maybe semi syn high mileage oil?

I'm sorry for all the questions but like I said I have no experience with Northstars and would be greatful for any knowledge from those who do. I've been wearing out the search button. :D

N*Caddy
02-19-11, 09:35 AM
First congrats on the new car and soon to be wife! (suppose to be the other way :))
Second WELCOME!
Now about the car, don't be worried about HG, that's just overinflated, is not as common as the Internet lets you think. Have you ever hear anything about HG in that Ford Ranger you mentioned? Probably not but I have seen a guy doing it on a 3 years old one just few months ago. What I am trying to say is not anymore common that in any other engine, it is more expensive though but that's about it.
The temperature gauge...even in my car (150K original untouched engine) the temperature is always just a hair above center. If I switch to digital readout (you can activate it in your car see at the end of my post how) the temperature is between 196*F and 212*F (depending on traffic). It is normal to go up to ~226*F, that's when the fans will kick in on HI speed and cool it down to ~208*F or so. Is the way the car was designed and meant to operate.
I always used the manufacturer recommended DexCool. I also use the manufacturer recommended 10WD30 regular oil. Coolant I change once every 2-3 years and add one (manufacturer recommended) sealant tab dissolved in the coolant before adding it in. My recommendation is stick with the manual, I am not reinventing the wheel for GM.
It is normal for the engine to take a while to cool down, depending on the outside temperature may take as long as 4h. Think about it, is a big lump of aluminum underneath a well padded hood and engine cover.

I would NOT recommend you to watch the digital temperature readout because first of all is a distraction and second, the temperature does fluctuates with engine load, outside air temperature, air movement in the radiator area....it could swing up and down between 196*F and 228*F within a matter of 1 minute. But is a nice gadget so here is how to activate it (just for your own curiosity):
Remember these:
FAN SPEED UP = YES
FAN SPEED DOWN = NO
Passenger warmer (up arrow) = Increment value
Passenger cooler (down arrow)= Decrement value
A/C OFF = Cancel/Exit
1. Enter into the diagnose mode (see here (http://www.cadillacforums.com/forums/cadillac-seville-cadillac-eldorado-forum/138258-how-pull-codes-dtcs.html#post1493022) how to, look at the picture to get your bearings on the above mentioned)
2. Either wait for the code sequence to finish or press NO or Cancel to skip it.
3. Once you are prompted "PCM?" press NO (as in I don't want that) to move to the next option.
4. The next option is "IPC?", press YES to access the IPC menu.
5. You will be prompted with "IPC Codes", "IPC Inputs"...press NO until "IPC OVERRIDES"
6. When prompted "IPC OVERRIDE" press YES to enter the IPC?>IPC OVERRIDES menu.
7. You will be prompted IPS00, IPS01 (option A) .... just press NO until you are prompted IPS05 (option E)
8 When prompted IPS05 press YES to enter IPC?>IPC OVERRIDES>IPS05 menu
9. Note where normally your trip computer is, a value between 1 and 255 displayed (factory default value is 43).
10. To activate the coolant temperature display add 64 to the value you see (i.e. 43+64=107) using the Increment/Decrement buttons.
11 To save the new value press and hold Front Defrost (symbol) and A/C buttons until the value flashes (about 1-2 seconds later).
12. To exit this menu press Cancel repeatedly until you are into the beginning sequence of the Diagnose mode (the bulb test). While all the dash lights and displays are ON press Cancel again and you are out. Alternatively just turn off the ignition key.

Here are the settings from IPS05 (Option E):
1=Inst MPG
2=Fuel used
4=MPH
8=AVG MPG
16=Engine RPM (not available on analog clusters)
32 = Battery voltage
64 = Coolant temp.

Submariner409
02-19-11, 10:11 AM
^^^ 100% truth. The 2002 is different in many ways, but N*Caddy's post is correct across the lines.

With NO A/C function set, fans go to SLOW at 224 degrees and FAST at 236. With an A/C function or DEFROST set, fans run in SLOW all the time. Your 16 psi pressure cap allows the coolant to heat to 265 degrees+ before it boils. Non-pressurized coolant boils at around 218 or so, so NEVER remove the pressure cap while the engine is hot.

Keep it clean, run it hard, and enjoy it. Absolutely get a real Helm/GM Factory Service manual............ eBay or www.helminc.com.

You might want to study up on heavy duty Fleet and Marine engine oils. Your engine has flat-tappet cam followers and the latest SM and SN "starburst" automotive oils have a reduced (by the EPA) anti-scuff additive package. Look at the 10W-30's offered as Shell ROTELLA, Chevron DELO, and Pennzoil LongLife.

Destroyer
02-20-11, 11:05 PM
Yeah, its a great engine and car. The head gasket issue is just overinflated. Not really an issue at all. Good luck with it. :canttalk: ..........................:histeric:

ThumperPup
02-21-11, 01:51 AM
welcome and good luck with the new used Eldo

Ranger
02-21-11, 12:48 PM
Dex got a bad rap and gets blamed for everything. Nothing wrong with it. Use it and change it every 2-3 years (or sooner).

The HG's are a problem and the '97 - '99 are the worst, but not all suffer it. Your temps and gauge sounds normal. It IS paranoia.

Timber Wolf
02-21-11, 01:09 PM
Thank you all. I've been looking into the oil and can't find 10w30 Rotella or Chevron Delo at Walmart. They have plenty of 15w40 in both brands. Didn't see Pennzoil Long Life at all. I'll go to my local parts house and take a look. Let me tell you I am relieved that the HG issue sounds worse than it is. I guess something has to be overinflated and it better not be the tires :-) Is it possible to rinse of my engine every now and then with the garden hose or is there something I should be wary about? Don't want to have an issue like those with the LT1 optisparks!

kckranz
02-21-11, 01:35 PM
I opt to spot clean the engine bay rather that get the garden hose out. A few minutes under the hose can equal forever chasing electrical gremlins - why risk it? Use a little Simple Green spray and a shop rag for your engine bay, use the hose to water those little flowers by the mailbox.

RippyPartsDept
02-21-11, 02:33 PM
:yeah:
spot clean - ftw
hose clean - ftl

Ranger
02-21-11, 02:42 PM
That Rotella 10W30 is rare as hens teeth.

I've used a hose with a fine spray or high pressure spray on mine, but I am careful not to flood the ICM, PCM, EBTCM or alternator.

Engine cleaner guns work well with not a lot of water if you have a compressor. They just spray a fine mist of water, solvent, soap or whatever you put in the siphon bucket. Mine is just like this one.

http://www.harborfreight.com/media/catalog/product/cache/1/image/370x/9df78eab33525d08d6e5fb8d27136e95/i/m/image_3727.jpg
http://www.harborfreight.com/engine-cleaning-gun-97014.html

Submariner409
02-21-11, 04:18 PM
A quick Google search for "shell rotella 10w30 dealer maryland" uncovered a skrillion places that will ship in cases or pails. The local Western Auto and the Route 301 Truck Stop up by Centreville carries it.