: 2004 CTS-V Navigation failure?



jgallowa
02-18-11, 10:58 PM
Guys,

After researching hundreds of posts, I decided to create a new one about my issue:histeric:. My 2004 CTS-V started spitting out the navigation disk a few months ago and when I put it back in it says "map dvd-rom not loaded". Before I go buying a new nav disk or take it to the dealer, is this a common issue? I have read that it may need a firmware update, as I bought the car used in 2007 and it's still the original 6.0 disk. Any thoughts on what to do next? Is the navi toast?

Thanks!

heavymetals
02-18-11, 11:22 PM
The navigation update will not fix this even though you need it to run a newer map disc.

CancerJCC
02-19-11, 12:16 PM
Could just be your disc. I have read of them just "going bad" over time as wierd and unlikely as it sounds. Or it could be your DVD-ROM drive just crapped the bed. And actually if you are somewhat handy I have a unit that the cd and dvd drives work in but the screen is busted that I will sell you. Believe it or not I just took pictures to place up on ebay this morning...

heavymetals
02-19-11, 01:41 PM
PM sent.

crazybiker51
02-21-11, 02:39 AM
with my disk in, it shows where i am etc, however there are no roads showing? i try everything and it just wont do it

CancerJCC
02-21-11, 02:19 PM
with my disk in, it shows where i am etc, however there are no roads showing? i try everything and it just wont do it

Pictures are worth a.....

Gishdream
02-23-11, 08:21 PM
I also have no roads on my nav screen.