: idle problem



tuercas
09-29-04, 02:30 PM
hello group imī a new member and this site is very cool,
imīa mechanic and i have a problem with a concours 94 nothstar mfi
the problem is at idle in hot,at normal temperature the isc rise the rpm hi and low a few times then go to normal operation i did check codes ( no codes condition) vacum leacks (ok) the isc works fine ( go out then in, no stuck)
the tps at idle in .65 mv, it changes when move the trotle and the idle switch is fine
i donīt know.... what to do
please help
:helpless:

Eldyfig
09-29-04, 11:37 PM
Had a problem like this. Check coil packs.

Geno Castellano
09-30-04, 12:21 AM
Could it be a misfire causing the ISC to react and rev the engine slightly to prevent a stall? Make sure none of the spark plug wires are misrouted causing electromagnetic interference with any of the engine speed sensor wiring which could cause a stray RPM glitch to the PCM and cause an unwanted reaction with the idle speed control motor.

Sounds more like a sticky or wearing closed throttle switch that's inside the idle speed control motor. When you depress the plunger of the ISC motor and feel the detent or click - that's the closed throttle switch that tells the PCM that the throttle is resting on the ISC motor and that the system is in control of the idle speed. If the switch is sticky and not "making" when the throttle is first closed it'll cause the PCM to extend the plunger causing a brief rise in idle speed.

You can check the operation of the closed throttle switch with the onboard diagnostics. Enter into the onboard diagnostics by simultaneously pressing and holding the off and warmer buttons with the engine idling until the onboard diagnostics activates. Read off any diagnostic codes displayed. When the system displays PCM? press the hi button to answer yes. Now that you are in the PCM mode of the onboard diagnostics the icons on the climate control panel will indicate certain functions of the control system. In particular, the lo icon on the climate control will indicate the status of the closed throttle switch. If the lo is lit then the switch is making and is closed. If the lo isn't lit then the switch is open. Move the throttle and watch. If the wandering idle is happening when the throttle is closed and the lo icon isn't on then the problem is likely with the closed throttle switch. Replacing the idle speed control motor is the likely cure.