: Help 2000 Catera no response to accelerator pedal HELP!!!



destinyintllc
02-05-11, 01:41 PM
One day I went out started my car went to take off and it just started jumping and wasnt responding to the gas pedal. I checked and replaced the spark plugs, replaced the valve cover gaskets, and the throttle body and still did not fix the problem. Im stumped now. The computer isnt kicking back any codes except a broken tail light which I knew. I am thinking it has to be either the accelerator sensor or the computer. Any suggestions and does anyone know what the cigarette pack sized box is by the fuse box under the steering wheel? Any help is very appreciated I love this car!!!

destinyintllc
02-05-11, 01:59 PM
It seemed to happen soon after I slammed the reverse/brake light in the trunk and I forgot to mention the TC light is now on never was on before

TitanCTS
02-05-11, 04:22 PM
Is your throttle body plugged in?

hgqguy
02-05-11, 04:25 PM
slammed the reverse / brake light in the trunk? This does not makes sence to me...you shut the trunk hard?

Your car is in power down mode. you said you changed the throttle body? did you have it reprogramed? If you change a throttle body It HAS TO BE REPROGRAMED.

Sorry what yr? 99-00 I assume.. check the connectors to the throttle body.. see if there is any moisture.. corrosion.. clean it up.

When my car did powerdwon mode the sport and tc light where on.

destinyintllc
02-05-11, 04:32 PM
Thanx for the response. Yes the throttle body is plugged in.......The lights that are on the trunk the covers are gone and didnt notice it hanging and closed the trunk. I changed the throttle body to try and fix the problem so that isnt whats causing it. Its a 2000 Catera 87k miles. I did notice one day that when I held the plug to the throttle body it seemed to idle a lil different. How do I get it out of power down mode?

destinyintllc
02-05-11, 04:32 PM
Thanx for the response. Yes the throttle body is plugged in.......The lights that are on the trunk the covers are gone and didnt notice it hanging and closed the trunk. I changed the throttle body to try and fix the problem so that isnt whats causing it. Its a 2000 Catera 87k miles. I did notice one day that when I held the plug to the throttle body it seemed to idle a lil different. How do I get it out of power down mode?

memphisrep
02-06-11, 05:55 PM
Im no mechanic but I'd be inclined to say computer issue.I had a 1995 Nissan maxima that was having some erratic idle issues but not throwing any codes. I cleaned just about everything I could think of IACV and such,ignition coils but anyway went to a junkyard and lucked up on an ECU and that fixed my issue

destinyintllc
02-06-11, 07:29 PM
thanx for the heads up thats my next move getting the throttle body programed and the computer checked

hgqguy
02-09-11, 05:43 PM
Must be done at GM dealer.. it touching the plug is making a differance then probly the problem was the plug to begin with. It may be moist or corroded. Once cleaned up the old throttle body should work ok. the old throttle body should always work with the car. if is stoped working it was not the trottle body itself. it was wires, moisture or corrosion, in the plus or the sensors. Clean and dry old throttle body since you have it off the car. Pop the end off where the plug is to be sure its all ok inside. then reinstall it to the car. It should work fine.

I had to cut the pigtail off the car that goes to the throttle body and splice in a new used one. then installed a newer throttle body and reprogramed it.

destinyintllc
02-09-11, 06:22 PM
thanks. The wires look good. I tryed to clean the old throttle body before I found the last new one in the country. I think I will go ahead and try and find a new wire harness and splice it as well. I mean it looks good, but your right and thats what I was thinking to thought it was just a bad conection. I have an appointment to drop it off Friday at the dealer for updates and programming. Hopefully I can find a new/used conector to splice before hand. Thanx again

retho78
02-09-11, 09:50 PM
If I remember correctly, you can program the throttle body by yourself. I had to replace my in laws 2001 catera throttle body last year and programmed it by following some steps. I cannot remember exactly how it was done...may be I have to search in my old subscribed posts in here.

retho78
02-09-11, 09:51 PM
Also , is the car turning on or the engine idling strange........could it be the MAF?

destinyintllc
02-09-11, 10:12 PM
yeah it starts everytime and idles pulsing between 900 and 350 I unplugged the MAF and no change in idle when I press the gas the idle pulses a little higher maybe 1200 rpm but continues pulsing and doesnt open up.

TitanCTS
02-09-11, 11:00 PM
Unplug one of your O2 sensors and start it and see if it changes idle, Do this one at a time for all 4 O2 sensors to eliminate them.

destinyintllc
02-10-11, 07:18 AM
Thanks I will try that today just unpluged each coil pack one at a time and tryed each one yesterday.

retho78
02-10-11, 09:55 AM
Have you checked the vacuum line going to the throttle body? Make sure it is connected and I think the throttle body learning procedure is....turn the key to ON for 30 seconds while leaving the engine OFF to resume the normal idle.

Give it a try and let us know.

Thanks

hgqguy
02-10-11, 07:16 PM
Im not trying to despute the reprograming idea.. however.. I did it with my car and it does not work. It may work on your exisiting TB but not on a new to car throttle body. Untll the throttle body is reprogramed by the dealer.. you are wasting money and time trying to figure out the problems.
the car will never work on the new TB untill u have it dealer programed. I have been through this.. with my own car.

destinyintllc
02-10-11, 07:31 PM
Vacuum line is hooked up. yeah I know hg I have tryed that it just resets the throttle position, but doesnt program it to the ecu. I am gonna have it dropped off after I check the O2 sensors. Thanks all for your input and advice.

retho78
02-11-11, 12:31 AM
That's interesting about the throttle body. I had changed the throttle body on my in-laws car couple years ago, got a used one from ebay...followed the same steps by the service manual and it worked for me.


Keep us posted!

destinyintllc
02-11-11, 07:43 AM
I also heard its better to take the 2000 Caterras to the BMW or Saab Dealers

hgqguy
02-11-11, 01:41 PM
the 3.0 is the same motor they use in the saab. also same as the l300 saturn v6.

destinyintllc
02-12-11, 12:42 PM
Well I had it towed to a GM dealer to have them program my throttle and update the computer. I pray it works because my 96 grand marquise I bought when the Catera went down about two and a half weeks ago just died on me.

WoW!!!!

30 day warranty, but I want my Caddy back!!!

Thanks for all the help will let you know

destinyintllc
02-12-11, 04:48 PM
Good news and bad news

Good news Its back in action

Bad news dealer said it was a bad wire harness, but couldnt tell me which one. I looked and cant see anything new. will try and find out Monday.

Throttle Body was already programmed so

either the key thing On for three minutes off the start worked
or
reseting the ECU by touching the Red and Black cables together for ten seconds reconnecting the battery wait til you hear it initialize then start the car.

Thanks again for all your help

elvin315
02-12-11, 09:04 PM
Isn't there a law saying they must return the replaced parts to the owner?

destinyintllc
02-12-11, 09:25 PM
not in Florida. and since they were closing and they did me a huge favor by doing it two days early and my other car broke down had to go with what they said. I think they prob just updated the ECU and programmed the throttle just said the other so they could charge me more.

Gota love Dealers

hgqguy
02-13-11, 01:40 AM
I will tell u from personal experiance... I tried 2 other throttle bodies on my catera.. neither worked untill reprogramed by the dealer.

It sounds like they reprogramed... Like I mentioned the pigtail to my throttle body was bad.. perhaps that is what they replaced. for future referance.. Always request your parts be returned to you when u take the car in... a reputable shop will automatically do this!... i found a shop that is OUTSTANDING in rochester ny!!