: oil filter



blanny431
02-03-11, 07:58 AM
Can someone please tell me exactly where this stupid oil filter is on my 1999catera also is that really the oil pan that is directly under the motor it has a quartr sized round shaped bolt with what loks like a star patterened head that looks a lot like a tranny fluid pan instead it An oil pan. Please let me kjow soon. Thanks kev

AHazzardToAll
02-05-11, 12:04 AM
Can someone please tell me exactly where this stupid oil filter is on my 1999catera also is that really the oil pan that is directly under the motor it has a quartr sized round shaped bolt with what loks like a star patterened head that looks a lot like a tranny fluid pan instead it An oil pan. Please let me kjow soon. Thanks kev

That is the oil pan. The trans pan is mounted on the belly of the trans with a fill bolt on the side. The trans pan has no drain bold, you have to drop the trans to drain the fluid. The 99+up cateras have the filter inserts or elements. The oil filter housing is located on the left (driver's) side of the block accessible from under the car. It is right above the CPS (Crankshaft Position Sensor). Try from going under the car right behind the driver's front wheel.

blanny431
02-05-11, 01:44 PM
thanks very much this is exactly what I need I cant believe I didnt see it the first time I was under there......wow isnt that funny that thread got like 87 hits but you were the only guy who knew where this stupid filter is.......I wonder if alot of folks have had this same problem...you know its also funny that when I went to napa to get this filter he brought it up on the computer and he brought me a dry filter and I said I dont think this is the right one(because I thought I had already changed it once ) so I went to the owners manual and sure enough it comes up with a screw on type in the manual....isnt that weird they have the wrong one in the manual!!!! any how now I gotta go back and change it in for t he right one.......hey thanks alot for the help everytime I have needed to know something about my cad I have come here and it has worked out every single time....good folks here......thanks again Kevin

AHazzardToAll
02-05-11, 03:59 PM
No problem, that's what we're here for. I'm sure several others knew the answer, but may not of had time to write out a description or may not have been members. I know there are several days I'll skim through the forum on my phone and view threads without the time to write out a full response. As for the manual having the incorrect filter, is it a 99 manual? I have never looked in the manual for changing the filter, but the 97 & 98 had a standard spin on filter, and then the 99up came with the inserts. Anyways, glad we could help.