: Olds Aurora Hesitating



Swishaa
01-05-11, 06:53 PM
I'm having some issues with my 2001 Oldsmobile Aurora V8.

During a recent 10 hour drive, my car started hesitating while cruising at a constant speed. Once the hesitating started, it would continue until I let off the gas or accelerated heavily. Under normal acceleration or when maintaining speed, the hesitation would come back either right away, or within a couple minutes. I found that putting the car into 3rd seemed to smooth things out, so I drove it that way the rest of the trip (about 3 hours remaining). It still occasionally had issues though.

Later on in the evening after a few restarts, the MIL came on. I checked the codes and read a P0386 and P1860. I know P1860 is related to the TCC. I had the TCC solenoid replaced about a year and a half ago after the MIL came on for that. I never had any issues driving at that time, and this appears to be a separate (but possibly related) issue.

Also, about a year ago I had the car stall on me while driving slowly through a parking lot. After that, the MIL came on and I read P0385. Nothing else ever came of that though, and eventually the light went back off on its own. I've had the car stall a couple other times since then, usually when slowing down to a stop.

I took it in to the dealer today, and they said they were able to eliminate everything outside the trans. They were getting abnormal readings from the TCC solenoid on the scanner while driving. Their best guess is that it's the wiring harness, so they rough quoted me $1250 to open the trans up and replace the harness. However, they weren't 100% sure what the problem is, other than that it's inside the transmission.

Currently, I only drive short distances. I haven't noticed the problem much since the 10 hour trip, but it has come up occasionally. The few times I've noticed it lately have been when accelerating or going up a hill. But it hasn't been as bad or as reproducible as it was during the long trip.

So, I guess I'm wondering if anyone else has had issues like this, or has any better ideas on what the issue could be. The car "only" has 77k miles on it, so I'm curious on what would cause such an issue. From what I've read, the 4T80E has been pretty reliable other than the TCC solenoids having to be replaced.

ThumperPup
01-05-11, 07:58 PM
I'm having some issues with my 2001 Oldsmobile Aurora V8.

During a recent 10 hour drive, my car started hesitating while cruising at a constant speed. Once the hesitating started, it would continue until I let off the gas or accelerated heavily. Under normal acceleration or when maintaining speed, the hesitation would come back either right away, or within a couple minutes. I found that putting the car into 3rd seemed to smooth things out, so I drove it that way the rest of the trip (about 3 hours remaining). It still occasionally had issues though.

Later on in the evening after a few restarts, the MIL came on. I checked the codes and read a P0386 and P1860. I know P1860 is related to the TCC. I had the TCC solenoid replaced about a year and a half ago after the MIL came on for that. I never had any issues driving at that time, and this appears to be a separate (but possibly related) issue.

Also, about a year ago I had the car stall on me while driving slowly through a parking lot. After that, the MIL came on and I read P0385. Nothing else ever came of that though, and eventually the light went back off on its own. I've had the car stall a couple other times since then, usually when slowing down to a stop.

I took it in to the dealer today, and they said they were able to eliminate everything outside the trans. They were getting abnormal readings from the TCC solenoid on the scanner while driving. Their best guess is that it's the wiring harness, so they rough quoted me $1250 to open the trans up and replace the harness. However, they weren't 100% sure what the problem is, other than that it's inside the transmission.

Currently, I only drive short distances. I haven't noticed the problem much since the 10 hour trip, but it has come up occasionally. The few times I've noticed it lately have been when accelerating or going up a hill. But it hasn't been as bad or as reproducible as it was during the long trip.

So, I guess I'm wondering if anyone else has had issues like this, or has any better ideas on what the issue could be. The car "only" has 77k miles on it, so I'm curious on what would cause such an issue. From what I've read, the 4T80E has been pretty reliable other than the TCC solenoids having to be replaced.

if that is truly what the problem is not saying it is but if that is well you can problaby get a transmision shop to do that work for problaby about 700 could get a used tranny for about 400 or 500 dollars and spend about 300 or 400 to have it put in
but thats about the same prices

not sure what els could cause the hesitation like that

mhamilton
01-06-11, 10:23 AM
P0386 is Crank Position Sensor B Performance... why didn't your dealer suspect this as a problem? They're well known to cause stalling/hesitation/stumbling problems on 2000-2002 models.

I wouldn't really suspect your TCC as the issue here. It may be malfunctioning, but even if it were slipping or switching on/off while driving, you wouldn't get hesitation. It would feel like the trans was hunting between gears and the revs would go up and down. Maybe a vibrational feel if it just slipped slightly under load, but not a hesitation.