: Turn Signal Problems on 1994 fleetwood



BigBodySwangin
01-04-11, 07:53 PM
I am having problems with my turn signals NEED HELP!!!! At first I thought it was my daytime running lights staying on until I check all bulbs and replace one burnt one is when my hazard lights started to go off without engaging them on. I have replace my flashers for both turn signals and hazards. That did not work. Than I replace my turn signal switch and yet that still did not help at all. Now I have no idea what to look for. What should I do now. This happen all of a sudden. I was park and waiting to pick someone on when I notice my lights turn on even tho my car was off and my twighlight sensor was all the way off. Whats going on does anyone know?

BigBodySwangin
01-05-11, 12:15 AM
anyone with any ideas out there?

csbuckn
01-05-11, 09:41 AM
So you have two problems? Turns signals not working and daytime running lights not turning off? What about power to the turn signal switch? Like a fuse or relay. For some reason, I think the two are related. How about the ground wire for the systems?

carnut
01-05-11, 01:22 PM
I'm confused? you say the the hazard flashers go off without touching the switch. Do you mean they turn on? What bulb did you replace? What exactly are the daytime running lights doing?

BigBodySwangin
01-05-11, 02:53 PM
Before I replace the front turn signal bulb I thought my running lights were on, but upon replacing the bulb I notice they were actually my hazards that were going off meaning yes being engage. I only have one problem and that is no turn signals

carnut
01-05-11, 02:57 PM
So, the hazards stay on? cannt turn them off, correct. Have you tried disconnecting the hazard switch. Turn signals will not work if the hazards remain on.

BigBodySwangin
01-05-11, 03:28 PM
I can turn them off now since I replace the turn signal switch.Before I had to remove the flasher because the way I use to turn them of was by engaging them which I guess grounded it out or something. But I can not figure why I have no turn signal

thefleetwoodguy
01-05-11, 07:32 PM
Im with carnut on this
can you clarify your problem
if I read ir right
your hazards are staying on?
if so its probably the hazard switch wires they are famous for smoking
when the 4 ways are left on,
since they tend to chafe somewhere in the column
you can bypass the hazard switch at the base of the column

BigBodySwangin
01-05-11, 07:47 PM
My hazard lights are working perfectly fine now with the new turn signal switch but i still have no turn signals

thefleetwoodguy
01-06-11, 02:35 PM
ok, you put in a new flasher for your 4 ways
did you replace the directional flasher as well?
its located on the steering column
so there are 2 flasher cans
1 for the haz lights 1 for directionals ~~~~~

BigBodySwangin
01-06-11, 03:26 PM
Yes I replace both

thefleetwoodguy
01-06-11, 06:03 PM
the turn signals operate off there own fuse
have you checked that fuse?
if that fuse is good you need to get in there with a test light and start following
the current path, its not a hard thing to do
I should have the schematic if you dont have it