: idle engine engine hot please help



poduff1978
01-02-11, 11:38 PM
Ok bought a 95 deville with 4.9 this summer stupid me didnt check and the guy had ran water this summer so the coldest day i found out i put it in my heated garage let it thaw drained filled no leaks expect in rad had to replace rad rad cap and t-stat fired up runs fines then came up with idle engine engine hot both fans came on shut off topped off started back up not leaking still same thing so i went and pulled codes and got ac High Side Temperature Sensor Circuit current Coolant Temperature Too High and Keep alive memory error any help would be greatly appriciated and was wondeing i have digital dash how do i get engine temp in degrees

the recluse
01-03-11, 09:06 PM
To get your temps in Imperial measurements, look for the US/Metric button on the A/C controller.

If your having to add water to the cooling system an your not seeing leaks, well, that's not good. Make sure the cooling system is completely full (no air in system) because if you have an air pocket in the system it will do what you are describing.

poduff1978
01-04-11, 02:50 PM
how do u get air pocket out ifs that what i have and my temp does not show up at all on my dash

the recluse
01-04-11, 06:48 PM
Usually when I replace my t-stats, I drill a 1/8" hole in it to allow air to pass through without reducing the operation of the thermostat itself. Otherwise, you have to let the system "burp" itself.

If you want to see your temps, go to your DIC and push the "Eng Data" button 2x's. The first one tells you the rpm's, the second tells you the temperature. The last button says "Engl/Metric", push it for Imperial units as apposed to Metric.